The node wait does not respect the scheduled time or node configuration

Describe the problem/error/question:

I created an example webhook where I have 3 nodes of type ‘wait’, after the execution of the second node wait or wait longer than 1 minutes the node does not execute or does not continue with the execution.

What is the error message (if any)?

no error message is displayed.

Please share your workflow

(Select the nodes on your screen and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version: 1.4.1
  • **Database : Postgres
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): Default
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): Docker Compose
  • **Operating system: Linux

Hey @denis.ursulino welcome to our forums!

The actual cut in n8n is 65 seconds.

Anything less than 65 seconds will keep the execution running (in memory) and resume after the period expires.

If you set a node to wait for more than 65 seconds, n8n will “stop” the execution (putting the workflow back in the database) and resuming it later.

This means the execution is offloaded, saved in the database until the time to continue approaches, and then n8n picks it up again.

Given it’s a webhook trigger, the http request will simply respond as soon as you get to the second node with whatever data n8n has. The execution will continue, but the http request will be responded and closed already by this time, since the execution has been put to “sleep”.

Does this clarify?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.