The Requested Webhook is Not Registered - Even After Activating

Hi,

I have got n8n up and created a simple telegram bot workflow like this.

I tried accessing both test and production webhook URLs, but both returns a {"code":404,"message":"The requested webhook \"GET 1/telegram%20trigger/webhook\" is not registered."} message. Can you please help me?

I did look at all the similar threads, but I still could not solve. I tried renaming and creating new workflows, still no luck.

Hi. I recreated the workflow with new names and it’s working now. But for the google sheets part, I am getting the following error.

ERROR: error:09091064:PEM routines:PEM_read_bio_ex:bad base64 decode
Error: error:09091064:PEM routines:PEM_read_bio_ex:bad base64 decode
    at Sign.sign (internal/crypto/sig.js:105:29)
    at Object.sign (/usr/local/lib/node_modules/n8n/node_modules/gtoken/node_modules/jwa/index.js:152:45)
    at Object.jwsSign [as sign] (/usr/local/lib/node_modules/n8n/node_modules/gtoken/node_modules/jws/lib/sign-stream.js:32:24)
    at GoogleToken.requestToken (/usr/local/lib/node_modules/n8n/node_modules/gtoken/build/src/index.js:196:31)
    at GoogleToken.getTokenAsync (/usr/local/lib/node_modules/n8n/node_modules/gtoken/build/src/index.js:135:21)
    at GoogleToken.getToken (/usr/local/lib/node_modules/n8n/node_modules/gtoken/build/src/index.js:77:21)
    at JWT.refreshTokenNoCache (/usr/local/lib/node_modules/n8n/node_modules/google-auth-library/build/src/auth/jwtclient.js:156:36)
    at JWT.refreshToken (/usr/local/lib/node_modules/n8n/node_modules/google-auth-library/build/src/auth/oauth2client.js:143:25)
    at JWT.authorizeAsync (/usr/local/lib/node_modules/n8n/node_modules/google-auth-library/build/src/auth/jwtclient.js:139:35)
    at JWT.authorize (/usr/local/lib/node_modules/n8n/node_modules/google-auth-library/build/src/auth/jwtclient.js:135:25)

I did verify that I added the key using the multiline editor in the format requested (three lines). Still I am unable to get it work.

Sadly the only thing I can say here is to try again. If the key got created correctly and all the /n replaced with new lines, it has to work. Did not come across a case yet where it was another problem.

Hello, I’m having the same issues. I get the below error even after activating the workflow. I have even recreated the workflow, still no luck.

Edit: I should mention this is for production URL. Test webhook url works well when I click the execute workflow button. Also i’m using the docker image version 0.76.0.

{
"code": 404,
"message": "The requested webhook \"POST 4/webhook/deploy\" is not registered.",
"stack": "ResponseError: The requested webhook \"POST 4/webhook/deploy\" is not registered.\n    at ActiveWorkflowRunner.executeWebhook (/usr/local/lib/node_modules/n8n/dist/src/ActiveWorkflowRunner.js:55:19)\n    at processTicksAndRejections (internal/process/task_queues.js:97:5)\n    at async /usr/local/lib/node_modules/n8n/dist/src/Server.js:998:28"

}

Welcome to the community @major7x!

If I test with the webhook path 4/webhook/deploy, which seems the one you have set, it works fine for me when I then it via curl -X POST http://localhost:5678/webhook/4/webhook/deploy. Can you please provide an example workflow and the curl command which lets us reproduce the problem you are facing. Thanks!

Hello @jan. Thanks for the quick response. Here’s sample curl for test and production hook. Test works and production hook does not.


you can click and expand the above image

Hey @jan , figured out the issue. it turns out that the web-hook URL generated in previous (docker) version is different from the new version. I had created my flow before upgrading docker image.

i.e.
I was using docker image 0.71.0 and the prod/test webhook URL generated has a number in it and was something like this https://fqdn.com/webhook/2/webhook/deploy & https://fqdn.com/webhook/2/webhook-test/deploy. Updated to image 0.76.0 but the URL in webhook settings did not change.

So… I recreated webhook node and got the prod/test URL without the number, something like this fqdn/webhook/deploy & fqdn/webhook-test/deploy. <— this works.

I guess it was working for test URL hook because it’s registered on an ad-hoc basis?

Great to hear that it works now.

Yes and no. For existing workflows the Webhook-URL should not have changed, only for new ones.

No matter if it is a new or an old workflow the on the node displayed Webhook-URL is the one that gets registered and should work if it gets used.

Have fun!