The service refused the connection - perhaps it is offline (N8N and NocoDB)

I have just freshly installed Docker, where I run N8N and NocoDB.

The issue is that I need help connecting both together. Getting error The service refused the connection - perhaps it is offline

The same issue was if I tried connecting N8N with supabase or Postgress. What is the deal with N8N and NocoDB. ?

Maybe some firewall? I did open 5678 and 8080 and 8000 port.

*** n8n version:Newest
*** Database - postgress:**
*** n8n EXECUTIONS_PROCESS setting - default**
*** Running n8n via Docker ****
*** Operating system: Windows 11

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
1 Like

Hey @Ivars_Pavlovich,

When you use localhost it is local to the machine / container running so in this case you are trying to connect to localhost on the n8n machine which isn’t going to reach NocoDB. Can you try changing the hostname to assuming the default docker network configuration for both containers this should work if not you will need to configure docker and the containers to allow communication between them.

1 Like

Thanks for answer.

is this my default docker IP?

Hey @Ivars_Pavlovich,

If that is the local docker network you would need to use which would be the gateway.


Worked! Thank you very much!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.