The session "{id}" is not registered

Describe the problem/error/question

I am running n8n in a kubernetes environment. I’m creating various workflows to test them. However, after some time after creating the pod, the following logs are left in the pod.

The session “{id}” is not registered.

When this log occurs, when I run the workflow manually, the execution result is not visible in the UI.

I saw that the same inquiry is at The session <id> is not registered, but there is no mention of how it was resolved, so I am registering the inquiry again.

The DB is using Postgres on a physical server.

What is the error message (if any)?

The session "65gwymuq7c5" is not registered.
The session "65gwymuq7c5" is not registered.
The session "65gwymuq7c5" is not registered.
The session "65gwymuq7c5" is not registered.
The session "65gwymuq7c5" is not registered.
The session "65gwymuq7c5" is not registered.

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.228.2
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): I don’t know how to get this info.
  • Running n8n via (Docker, npm, n8n cloud, desktop app): on kubernetes
  • Operating system:

Hi @jaemin_park, welcome to the community!

I am sorry you are having trouble. This message is thrown when the n8n server can’t find a connection for its SSE messages. If this happens only occasionally a simple page reload will typically fix the problem.

Seeing you are using K8s I suspect you have additional services between n8n and your browser which might need additional configuration here. Nginx for example would require configuration similar to the one discussed here in order to proxy such messages.

When using external services in your routing (such as Cloudflare) there is also a good chance these might cause additional problems depending on their setup. So you would want to ensure these don’t cache anything or otherwise interrupt/reset connections.

Lastly it might be worth checking if websockets work better for you. These will replace SSE in v1 of n8n, but you can already use them by setting the N8N_PUSH_BACKEND=websocket environment variable.

1 Like

First of all, I’ve added the websocket settings to n8n as per your solution. I’ll have to wait and see, but it seems to have resolved the above issue. Thank you.

1 Like

btw. that normally occurs also when n8n gets restarted and a browser session is still active. So your browser is connected via a specific session ID. When n8n restarts, the sessions get deleted as they only exist in memory. But because the browser does not know that, does it try to use that push connection session, which is not valid anymore, and for that reason will the terminal then print that info message. As @MutedJam pointed out, will a simple refresh fix that.

1 Like

As you say, something similar can happen after an n8n restart, but it’s unlikely to be a frequent occurrence, so I think it’s a negligible situation

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.