The session “ID” is not registered

When the Telegram trigger is launched, “The session “ID” is not registered” appears in the logs. There is no output in the editor. Please help.

Please share your workflow

My config ngnix contains:

server {
listen 80;
server_name vv.dolov.ru;
return 301 https://$host$request_uri;
}

server {
listen 443 ssl;
server_name vv.dolov.ru;

ssl_certificate /home/web/conf/web/vv.dolov.ru/ssl/vv.dolov.ru.pem; # путь к вашему сертификату
ssl_certificate_key /home/web/conf/web/vv.dolov.ru/ssl/vv.dolov.ru.key; # путь к вашему ключу
ssl_stapling on;
ssl_stapling_verify on;
resolver 8.8.8.8 8.8.4.4 valid=300s;
resolver_timeout 5s;
error_log /var/log/nginx/error.log;

location / {
    proxy_pass http://127.0.0.1:5678;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection 'upgrade';
    proxy_set_header Host $host;
    proxy_cache_bypass $http_upgrade;
}

}

docker compos contains:

version: ‘3.8’

volumes:
db_storage:
n8n_storage:

services:
postgres:
image: postgres:11
restart: always
environment:
- POSTGRES_USER=${POSTGRES_DB}
- POSTGRES_PASSWORD=${POSTGRES_PASSWORD}
- POSTGRES_DB=${POSTGRES_DB}
- POSTGRES_NON_ROOT_USER
- POSTGRES_NON_ROOT_PASSWORD
volumes:
- db_storage:/var/lib/postgresql/data
- ./init-data.sh:/docker-entrypoint-initdb.d/init-data.sh
healthcheck:
test: [‘CMD-SHELL’, ‘pg_isready -h localhost -U ${POSTGRES_USER} -d ${POSTGRES_DB}’]
interval: 5s
timeout: 5s
retries: 10

n8n:
image: docker.n8n.io/n8nio/n8n
restart: always
environment:
- DB_TYPE=postgresdb
- DB_POSTGRESDB_HOST=postgres
- DB_POSTGRESDB_PORT=5432
- DB_POSTGRESDB_DATABASE=${POSTGRES_DB}
- DB_POSTGRESDB_USER=${POSTGRES_NON_ROOT_USER}
- DB_POSTGRESDB_PASSWORD=${POSTGRES_NON_ROOT_PASSWORD}
- N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
- N8N_PORT=5678
- N8N_PROTOCOL=https
- NODE_ENV=production
- N8N_PATH
- WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
ports:
- 5678:5678
links:
- postgres
volumes:
- n8n_storage:/home/node/.n8n
depends_on:
postgres:
condition: service_healthy

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Thank you, no more help needed. My level is noob. I spent a long time fiddling with different settings and configuration options. However, the easiest option for noobs is the following:

Maybe this instruction will be useful for noobs, since you don’t need to understand the intricacies of the configuration SSL. Instructions found here: https://youtu.be/rEdruJHQ4KQ

2 Likes

Welcome to the community @vassilevev!

Great to hear that you found a solution, and very nice of you for already giving back and sharing your solution with the community.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.