There was an error initializing DB: "connect ETIMEDOUT"

N8N is installed in version 0.151.0 with helm in an Openshift cluster.
N8N is connected to a remote (from Openshift point of view) MySQL database.
In principle it works very well
We shutdown N8N every evening and start it next morning.
From time to time, we see the error message

“There was an error initializing DB: “connect ETIMEDOUT””
“Stopping n8n…”

Seems that the message comes when the servers are busy at the start time.
Is there a way to increase the timeout with an environment variable?

I don’t think there’s a suitable option for increasing the db connection timeout via environment variable yet unfortunately (though this could be a good feature request).

I am not a helm user myself, but would it possibly offer the option to define a dependency to wait for before firing up your n8n pod which could do the trick for you?

1 Like

I have a running POD to which I can login,
uname -a
Linux n8n-f786f4d56-t7l7s 4.18.0-305.25.1.el8_4.x86_64 #1 SMP Mon Oct 18 14:34:11 EDT 2021 x86_64 Linux
Only from time to time the error happens.
It is possible to login to this POD and modify the configuration.
I am not able to find the configuration in LINUX that is to be modiffied to increase the timeout.
Any ideas on this.