Timezone Environment Variable

I’m running a self-hosted node on a DigitalOcean droplet and everything works great except for the GENERIC_ENVIRONMENT variable and the TZ variable. I keep getting a “Default - Default timezone not valid!” error message in the workflow settings. I have tried values with quotes and without quotes. Even the default Europe/Berlin value gives the error. This leads me to three questions:

  1. If I’m using a docker-compose.yml file should the value be in quotes or no?
  2. Where can I find a list of valid timezone values that the variable will accept?
  3. Do I need to restart the docker container in order for .env file changes to take effect?

Thanks in advance for any help you can provide!

Hey @pford,

Just curious what is the exact wording of the error message and share your options (removing anything important)?

You can find a list of time zones here: List of tz database time zones - Wikipedia

When changing the .env file normally just a restart of the container is needed.

1 Like

Thank you for the response and the list of timezone values. Here’s the error that I get:

I will try a restart of the container and see if that helps.

Okay so a restart of the container did fix the issue and for others who may have the same question in the future - I used quotes around the value and the values from the list @jon linked using a docker-compose.yml file with a .env file. Rebooting the server and restarting the container fixed it.

2 Likes

@pford that is good to hear, I don’t use quotes in my docker files but I suspect that comes down to the file version and if you are using key:value or key=value in the compose file.