Too_many_write_operations dropbox

Hello, I have a question regarding this error: too_many_write_operations dropbox. How can I fix this problem?

Hi @Max_T, which node in your workflow exactly throws the error? If it’s happening inside your loop you could start by adding a Wait node before each HTTP Request, meaning you wouldn’t send as many requests at once if your loop keeps running for a while.

The error reports the last http (@) element named:Tworzenie linku udostepniajacego . Is out of the loop.

Are you sending a large number of items at once to this node? If so, you could try using the batching options offered by this node to only send a limited number of requests per interval:


ok and i’m already checking

The first module (sheet) takes quite a lot of lines. Only 27 reach the module related to the dropbox.

unfortunately it didn’t help

Good idea to split the data into bundles, but I have to figure out how to split the data some other way for this scenario.

I rewrote the scenario a bit. So far, this splitting into parcels does not work.

It spins endlessly.
Zrzut ekranu 2022-09-01 125500

Zrzut ekranu 2022-09-01 125914

Hey @Max_T, there is a chance one of your requests fails and your execution crashes behind the scenes. The HTTP Request handles this poorly at the moment I am afraid. You check the server logs for any trace of that if you’d like to be certain.

You can, however, improve the behaviour by adding and enabling the Full Response and Ignore Response Code options:


This should provide a little more information about what is happening and prevent the execution from crashing.

“You check the server logs for any trace of that if you’d like to be certain.”

I didn’t look into that. Is it about logs and a dropbox? As I enabled what you said, it reported an running error the first time. It was a too_many error. In subsequent attempts, this error was not there anymore. So the automation can work with these options turned on, or do I need to look for another solution?

Do I think right?

Sorry, I meant you can check the server logs. But it’s probably not super helpful anyway and won’t resolve the issue anyway even if confirmed.

So instead you might just want to use the HTTP Request node options Full Response and Ignore Response Code in case you encounter any such errors again going forward :slight_smile:

Ok. So this is the solution. Thank you very much.

1 Like

Now I have another problem. The sheet module does not keep up with writing links to sheet.

Hey @Max_T, what exactly do you mean by that?

When the module that creates the links does its job, it passes the links on to the sheet module, which saves them to a file. Unfortunately, not all links are recorded in the sheet.

Ah, I seem to remember this happening before. Google Sheets API isn’t really suitable for writes in very fast succession as it doesn’t immediately report a row as being written into. So rows might get overwritten in such scenarios.

You could consider using a more suitable database here or add a wait between each batch of data you send to Google Sheets.

Sorry to change that, but I improved the schematic.