Traefik Default Cert

I followed this setup step by step for deploying using Docker Compose in a DigitalOcean Droplet

https://docs.n8n.io/reference/server-setup.html

Everything seems to work except the certificate, for some reason I get the following

I’m not very experienced with certificates and docker images but for what I understand traefik should generate a certificate through letsencrypt similar to what one can do with certbot and apache right?

Welcome to the community @Leonidax!

Yes, you are correct. If you follow the guide and everything is set up correctly it should create a valid certificate for you. So considering that it is not, I guess there is something wrong.

I would advise using instead of the command sudo docker-compose up -d just sudo docker-compose up. You should then see the output of the services and so also any error messages which should tell you what is going wrong.

If that does not help it would probably be best to post in a traefik forum and ask for help there. I have sadly not much experience with traefik myself but they will probably have directly an idea what could be going wrong.

@jan perfect that’s what I needed, seems like my permissions where too open for Traefik, I run the docker-compose as you suggested and then I got the following log

I just changed the permissions and now it works like a charm…

:slight_smile:

That is great to hear! Have fun!