Triggering Airtable on updated specific field?

Got a field Following and a Last Updated (FollowingSince) on that specific field. Any try to trigger that way ended in a ERROR: The Field "FollowedSince" does not exist.



It works fine if Last Updated is “global” :



n8n in a docker on own ubuntu 22.04 server

Hi @Thierry, welcome to the community! I am sorry to hear you’re having trouble.

I tried creating a trigger for a FollowedSince field and this seems to have worked fine for me:

I configured this field to trigger on another field just like you described:

Could you try reading your table with the regular Airtable node and share the output to verify n8n can access it, like so?

Sure. regular airtable node works fine

.


But I could not find a way with the Last update date on a specific field. Just had to do it “global” last update and check value with a If node. Not perfect but it works.

Dunno. Maube I did something wrong. Or maybe this is an issue with the tracked field : in my table, FollowedStatus is a Single select associated to an automation (button clicked).

I seem to have come across the same issue.

(n8n v0.193.3, docker, postgres)

The datetime field is successfully retrieved when calling from an Airtable regular node, but when trying to use the same field as the trigger field in an Airtable trigger node, it gives an error “The field does not exist”.

Note: the Airtable Trigger node works just fine if the same field is converted, in Airtable, to a global trigger instead of a field-specific trigger. Although, i’m not sure why there’s such a difference, as both the (datetime) field types (in Airtable) are exactly the same.

Hm, I still can’t reproduce this I am afraid. I wonder if the Airtable API behaves different for my account for some reason (perhaps because it has some legacy status or something). When saying datetime field, are you referring to the trigger field itself or have you also configured your trigger field to observer changes to a datetime field?

@Jon anything obvious you can think of in the respective trigger node code that could cause these problems here?

Hey @MutedJam . When i say the datetime field, i mean the field itself.
I’ve tried configuring that field to observe changes in various types of other fields for its trigger, all with the same result.

Hey @shrey-42,

Are you able to make an example base that we can clone to test with?

Hi, similar error for me as well.

I had two automations working using two separate workflows and triggered by two separate bases.

These were both used to send messages via twillio to a group of contacts when a record is created in airtable (triggered by a date field and polling every minute).

Both of these were working okay including, most recently, this morning.

I then made a change to one of the automations. I added a new text field to pass some placeholder information for the twilio message. I did not change anything to do with the created time field.

When I came to execute the workflow I receieved the error: “Airtable Trigger: The Field “created” does not exist.”

I have not been able to fix this by recreating the date field or by copying to a new base.

Interestingly, the second automation (which is totally separate base and workflow) now also gives the same error (despite not having changed anything to the base or workflow).

Cheers, James

Hey @james_backpedal,

Welcome to the community :tada:

Do you have an example public base I can copy to try and reproduce this?

Hi Jon,

This is a duplicate (and cleaned) version of the base where the issue happened. The “whatsapp n8n triggering” is the one that holds the info fed through to n8n.

Thanks for the help

2 Likes

Hey @james_backpedal,

Thanks for that, I have copied it and used the whatsapp n8n triggering table and created as the field but for some reason I can’t reproduce the issue from the initial setup I then added a field to the table but this doesn’t appear to have stopped it from working :thinking:

What happens fi you delete the trigger node then add it again does that help? What version of n8n are you running as well?

Something i noticed, the trigger node works fine when the wf is activated.
But, if we try ‘Fetch Test Event’, it errors out.

I can second this. I hadn’t tried this until you mentioned but I see the same.

Hey Jon, I deleted the trigger and readded it to the wf and I have the same error.

To test something, I then created a new table in the same airtable base.

I updated the same trigger in the wf to this new table and it fetches a test event perfectly.

I’m using the webapp.

Hi Jon, I’ve figured it out.

Essentially it is because some of the records in my DB did not have a “created” field anymore. So it is actually a super simple explanation, apologies.

To talk you through why I did this:

  • I am using airtable to trigger messages to a lot of people at once via whatsapp

  • I want these messages to send quickly when I am ready, so I have n8n set to 1min polling time

  • But, I need to add quite a bit of info to each record before it sends. (eg which agents, what is the message)

  • This means that there was a risk that the polling trigger of 1 minute would fire before I have filled in all the info

  • To solve this in airtable I just built a simple automation to set a date field to “created time” when I update the status

  • As part of testing this I wanted n8n to pull in the more recent records so I cleared the old “created time”. This is when the error occurred.

  • To narrow this down further I’ve now found that it is ONE specific airtable record that causes this error. I can delete “created” from all records apart from this one and n8n fetches the test event correctly,

  • As soon as I remove “created” from that record it breaks.

Happy to show you this on screenshare etc if helpful.

1 Like

Hey @james_backpedal,

That is interesting so it is more that if a record doesn’t have a field the test fails? That is a bit annoying but if you can maybe record it failing I have a chat with one of the other engineers and we can have a think about how we can handle that sort of case.

1 Like

No worries here you go: Loom | Free Screen & Video Recording Software | Loom

1 Like