Twitter oauth gives 403 error

GM all.

After not having found a solution for this challenge Looking for a challenge? (filtering twitter webhook events) - #4 by bees8 , I have succesfully deployed a n8n instance on digital ocean. I would only use this for receiving twitter webhook events, as I prefer the stability of n8n cloud for the rest of my workflows.

Receiving the twitter events work amazingly great!

If someone sends a DM, I would like n8n to reply. The Twitter node has this option. The issue I am having right now, is that it returns a 403 error: “There was a problem generating the authorization url”

I have tested with the same setup on n8n cloud, and there it works perfectly.

What am I missing?

Thanks in advance!

I have also tried using the generic oauth credentials.

I’m getting a similar error, just 401 this time

It seems this person has the same issue: Second twitter account 401 error - Questions - n8n

There’s a few of us. A FEW!

Hey @bees8,

Twitter can be tricky, I don’t think we support the v2 option yet so there could be something there. I take it when you tried to connect with the Twitter node you had your consumer key and secret filled out?

I think I had to wait for Twitter to approve my app as well before I could use the API properly.

Hey Jon! Thanks for your reply.

yes filled it out exactly the way I filled it out on n8n cloud :slight_smile:
on n8n cloud it works, on digital ocean droplet it does not.

Hey @bees8,

That is odd, It shouldn’t matter what location is used things should work the same way. When trying from Digital Ocean do you see the error when clicking on the sign in link or before?

How have you installed n8n as well is it with docker, npm or something else?

I’m getting the error once I click the ‘connect my account’ button - almost instantly.

I’ve installed n8n using docker, and followed exactly the n8n digital ocean droplet tutorial (which was very good, thanks!)

Is that this one? Digital Ocean - n8n Documentation

1 Like

that’s the one!

Perfect, I will grab a coffee and give it a quick bash and see if I hit the same error.

1 Like

Well good news, I have reproduced the issue. Not sure what is going on there but I will have a solution soon.

On your setup did you complete setting up the owner account?

1 Like

That good news indeed! I’m not a complete idiot :grin:
What do you mean with complete setting up the owner account?

When you first login it will ask if you want to create an account, Did you do that or skip that?

Oh I cannot remember, I believe I did yes - that’s also the one I use to log in :slight_smile:

Hey @Jon - any updates? :slight_smile:

Hey @bees8,

Nothing yet, I got caught up with some issues. This is back on my list for this afternoon.

1 Like

Have same problem (my n8n deployed on Railway).

If not solution, but maybe any workaround?

Hey @neoromantic,

Welcome to the community ::raised_hands:

How do you have n8n set up on railway?

I still have the same issue, as a workaround I now use pipedream.
Basically, n8n workflow gets triggered, if there needs to be a reply given within twitter, I trigger a pipedream workflow :slight_smile:
fyi @Jon

1 Like