Typeform throwing error

When I use the typeform trigger, I always get this error when executing:
Error: Typeform error response [400 - errorBody.code]: an error occurred when parsing the request err (localhost as url is not allowed)

Has anyone seem this?

Screen Shot 2020-02-07 at 5.50.04 PM

Looks for me like you are testing locally but you forgot to activate the tunnel:

I see, but this is a remote server (I’m hosting n8n on a personal remote ec2 instance). Would I still need to use tunnel? I can’t get webhooks to run locally either when using tunnel.

Here’s my start command, any advice would be appreciated:

docker run -it --rm
–name n8n
-p 5678:5678
-e DB_TYPE=mongodb
-e DB_MONGODB_CONNECTION_URL=“XXXX”
-v ~/.n8n:/root/.n8n
n8nio/n8n
n8n start --tunnel

Running it on an EC2 makes only a difference here if you configure n8n correctly that it knows how it is reachable. Theoretically, you could set the WEBHOOK_TUNNEL_URL to the IP address of your server but that will make problems with many services as they expect a properly setup domain with SSL certificate. If that can not be found they will not allow it to be used for webhooks. So I advise you to follow this guide:
https://docs.n8n.io/#/server-setup
That takes care of everything.

Ah and just saw that you said you can not get the tunnel running. That is very strange. I just tested it and also with the Typeform-Trigger Node. It works totally fine. So no idea why it should not work for you. Maybe your firewall is blocking it or something similar.

If you start it, it should display something like that. And if it does the tunnel is running.

Waiting for tunnel ...
Tunnel URL: https://ec3...74.hooks.n8n.cloud/

If it does not work anyway, you really have to check if something is blocking it.

Thank you! I was able to get the webhook running locally but still no luck with the remote server. For context, I have it running on AWS Elastic Beanstalk using docker and did set the WEBHOOK_TUNNEL_URL as an environment variable. Is there anything else I am missing to get this to work?

I have an SSL certificate provisioned too.

Also worth adding this is my dockerfile:

FROM node:10
WORKDIR /usr/src/app
COPY . .

ENV DB_TYPE=mongodb
ENV DB_MONGODB_CONNECTION_URL=“XXXXXXXX”
RUN rm -rf node_modules
RUN npm install && npm run build; exit 0
EXPOSE 5678
CMD npm start

Again I would strongly recommend that you follow the setup I did prove above as it includes already everything. If you set up the reverse proxy yourself there is a very high chance that it will cause problems with the UI not updating correctly, webhooks beeing blocked, …

If you check the setup I did sind you can find all the environment variables you should set for everything to work properly and almost even more important, to be secured (else everybody which knows the URL can take over your server if n8n is not secured):
https://docs.n8n.io/#/server-setup?id=_5-create-docker-compose-file

If all of them are set correctly and n8n is reachable as configured it should work fine.

You can check very easily if it uses the correct webhook URL is by simply creating a Webhook-Node and opening it. You can then click on “Webhook URLs” and it will display you then the URL n8n uses. If it did not work, the URL will contain “localhost”. If it did work it will contain whatever you have set.

Thank you, the WEBHOOK_TUNNEL_URL seems to have fixed it!

That is great to hear! Wish you a great weekend!