UI nodes position BUG

Hello!
Seems like there is some bug in the new UI Vs. 0.173.1

New workflow, changed some names on the nodes, made them look organized and saved. No mater how many times I save once I close and open again these dont keep the saved position.

Regrads,
Andres

1 Like

Hi @pradilla

I’m using n8n v0.173.1 and I’m not facing any similar issues.

  • Can you try clearing your browser cache and check
  • Or maybe a different browser?

Hey @pradilla,

Are you using a device with a touchscreen?

1 Like

My laptop does have a touchscreen.
Tried chrome and firefox. still not able to get the positions to save.

Hey @pradilla,

This is likely going to be down to a known issue with touch screen devices, As a temporary solution if you don’t use it you can disable the touch interface and that solves the problem.

disable as in an ENV variable?

I’m on 0.172.0 and also having this issue. I don’t use n8n from touchscreen devices.

No matter what I move the Patch request sent does not include the NEW coordinates.
For example I moved the start node and saved. Position is always the same in the payload.

New workflow. Renamed and network shows a post with this position: (240,300)
image
Then, added another node, moved start down and saved:
Start node still shows 240,300 (but it has moved down)
image

Sadly not an env option it would be an OS setting for Windows the steps are here: Enable and disable your touchscreen in Windows

We are working on fixing this, You find another thread about this issue here: [172.0] Nodes position not saved - #2 by Mutasem

@jhambach that is interesting all the reports so far have been down to a device with a touchscreen (laptop, tablet that sort of thing), do you have a touch screen monitor or anything? What browser are you using? We have tried on a few different configurations and have not been able to reproduce on a non touch device.

I am running a recent version of Chrome on both machines I run it on (both on Windows 10)

One of the computers is a Surface Book 3, but I run it docked and the monitor I’m working from is non-touchscreen. On the other computer both monitors are non-touch.

Hey @jhambach,

I think the surface devices are touchscreen so docked or not that is likely to be the problem. You could try disabling the touch input at the os level which could work.

Is the other device a surface or similar as well?

No it is not, it’s a custom built desktop. I’ll try disabling touch on my Surface and see if that makes any difference!

If it helps we have a fix in place that will be available soon so it will be interesting to see if that fixes the same issue.

It could be worth checking on your desktop if it thinks it has touch enabled as well.