Unable to get Slack channels

Hey guys,
I can not get channels list. Authorization was succesful and the bot is the channel what I am looking for. I added him to the private and also to the public channel:

Based on the community topics I set permissions channels:read and groups:read + more than that

Its still not working. :confused:


It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Version 1.19.5

Hey @Tomas_Stekly,

Channels:read should be all you need, Is it possible that you are using oauth instead of a bot token as that can change things and you would need to make sure the scope is attached to the correct authentication type.

After updating the scopes did you also reinstall that app into your Slack workspace and have you already tried clicking on the 3 dots next to fixed and selected refresh list to see if it brings them in?

Hey Jon, I tried everything you mentioned.

Problem still occurs

Hey @Tomas_Stekly,

Which authentication type are you using?

@Tomas_Stekly , I use HTTP Request node to pull all the channels (not sure why not Slack). Nonetheless, it works fine for me. It is an old workflow when pagination was not embedded yet (so I had to utilize a few extra nodes to paginate and join all the iterations) but it works fine for me. I can share it with you here.

Here’s my user permissions (there are many as it does a lot of things for me)


Hey Jon,

I tried both of them.

Did you have permission set for both? If you use the access token for a bot you would need to make sure the bot token has the permission added.

Once the scope is added you will need to make sure the app is installed in the workspace again so it can pick up the new permissions.

I’m also having this problem. It actually seems to be related to the channel list generating, since if I manually set the channel by name and test the node the message will send.

Hey @glances,

Welcome to the community :tada:

This is normally related to the permission not being enabled, Once the permission is enabled the app needs to be reinstalled into the workspace which sometimes gets missed.

Yeah I meant I’m having the same issue because all of the correct scopes are granted to the bot, just like the OP:

I’ve added a bunch of scopes and reinstalled to the workspace around 5 times, still nothing. I’m on the cloud version (1.25.1) by the way!

Hey @glances,

For me it is working as expected…

In your node are you using the bot access token or OAuth? Can you try running the workflow below as it is and select your Slack Credential this uses the same API call we make in the node so it will be interesting to see if you get a list of channels back or an error message.

Hey @Jon!

I’m using a bot access token. Copying that workflow and passing the same credentials returns all of the Slack channels! Very weird.

Hey @glances,

That is very odd as the API call is the same :thinking:

Do you see any errors in the browser console when trying to use the node maybe under the network tab?

500 Internal Server Error.

Do you have an expression with a lot of data in it in the node?

Not really. Even if I remove all of the message data it won’t load the list of channels:

I am fresh out of ideas, I think it still might be expression related but without seeing your instance and having a play it is hard to say. I have done some testing with other slack and n8n instances and I just can’t get it to fail.

Same error here. open source version installed.

error 500 in the console log.

version 1.33.1