Unable to get Todoist Auth to work

Let me first state that I installed n8n via the catalog in the web admin of my self-hosted (on a RaspberryPi 3) Yunohost.

Describe the issue/error/question

I set up API auth for Todoist using the API key from my account and, when I try to connect it, I get the message:

Couldn’t connect with these settings
Your request is invalid or could not be processed by the service

with no explanation.

Trying to use Oauth2, I followed the instructions in the documentation, entered the right id and secret, copied over the callback URL, attempted to connect and get the response:

  "code": 0,
  "message": "Insufficient parameters for OAuth2 callback. Received following query parameters: {\"error\":\"invalid_scope\"}",
  "hint": ""

I’m not sure how to add a parameter to the callback, if that’s what this will solve this, but I think it has to be a scope, according to the documentation. Would figuring out how to add this resolve the connection issue?

What is the error message (if any)?

See above

Please share the workflow

Share the output returned by the last node

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
    at Object.todoistApiRequest (/var/www/n8n/node_modules/n8n-nodes-base/dist/nodes/Todoist/GenericFunctions.js:26:15)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async GetAllHandler.handleOperation (/var/www/n8n/node_modules/n8n-nodes-base/dist/nodes/Todoist/OperationHandler.js:93:28)
    at async Object.execute (/var/www/n8n/node_modules/n8n-nodes-base/dist/nodes/Todoist/Todoist.node.js:579:36)
    at async Workflow.runNode (/var/www/n8n/node_modules/n8n-workflow/dist/Workflow.js:658:28)
    at async /var/www/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:585:53

Information on your n8n setup

  • n8n version: 0.203.1 *(I can’t figure out how to upgrade it. npm update -g n8n returns I am already on the most current version.:man_shrugging:)
  • Database you’re using (default: SQLite): Don’t know how to check but whatever was installed by the stupid-user installation I did on my Yunohost.
  • Running n8n with the execution process [own(default), main]: Not sure how to tell. Didn’t change anything from installation.
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: It’s on a Yunohost, so npm maybe?

Hey @starlord,

Welcome to the community :cake:

It sounds like an upgrade is needed, To do that assuming you did install with npm you could try npm install -g [email protected] which should take care of it. There is an issue with the OAuth option that I am aware of but the API Key I know works as I use mine a few times a day :slight_smile:

I tried this but I am still getting the same error messages. I used SSH to get into my Yunohost and ran npm install -g [email protected] and it appears to have done something and the n8n app is no longer telling me I am several versions behind, but the credentials for both API and Oauth2 are both still giving the same errors.

Edit: The UI now says I’m still back on 0.203.1 so I guess the upgrade didn’t work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.