Unable to login to n8n Desktop app on Windows (no password recovery)

Describe the issue/error/question

Hello, I have installed n8n Desktop on Windows. I have set up a first workflow.
When I returned on n8n, I was unable to connect. I can’t remeber the password and when I click on “Forgot my password”, impossible to retrieve it.

What is the error message (if any)?

“Please contact your admin. n8n isn’t set up to send email right now.”
Capture d’écran 2022-05-20 004613

Information on your n8n setup

  • n8n version: 1.4.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: ???
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: desktop app
1 Like

Hey @faba,

Welcome to the community :cupcake:

You might be able to use the CLI tool to reset the password by using n8n user-management:reset but depending on how complication the workflow was it may be quicker to remove the .n8n folder from your users install path and running it again so that it does the initial setup.

On Windows the CLI tool can be found here:

C:\Users\<username>\AppData\Local\Programs\n8n\resources\app\node_modules\n8n\bin\n8n.cmd

I tried to launch the CLI tool but there is an error :

P.S. my workflow is (was ? :wink: :sweat_smile:) quiet complex…

Hey @faba,

You would need to use something like .\n8n.cmd user-management:reset you might also be able to export the workflow with .\n8n.cmd export:workflow --backup --output=backups/latest/ as well which would save your workflows in a backups\latest folder.

Thx @jon.
After installing nodeJS, I achieved to export my workflows. It is the most important point.
Nevertheless, still unable to connect even after resetting user management :

Problem setting up owner
Request failed with status code 401 

I think I will have to reinstall n8n desktop…

I am also not able to log in with same error output

Hey @faba,

That could be the best option, If you delete the ~/.n8n folder it might do the trick.

@Prem_Patel are you also using the desktop version of n8n?

Yes! I’m using windows app but stuck here…

Hi @Prem_Patel, fellow Windows user here, the approach suggested by @jon should also work on Windows.

Moving or deleting the .n8n folder in your home directory (C:\Users\<username> on Windows) would let you start from scratch with a blank n8n database (without any users or workflows - so make sure to run a backup if you’d like to keep your workflows).