Unable to login with Desktop Mac N8n after update

Hi all,

I’m having issues with my desktop n8n. I went and updated it to the latest version, but it is now showing the email login page, with no option to disable user management. I checked my config file and it’s set to basic auth but those credentials aren’t working on the user management login page. Any ideas what I need to do to disable it for desktop?

Hey @djangelic,

My first thought is are you editing the desktop env file or another one?

Hi Jon, editing the desktop env file. Going to give it SMTP access and hopefully that will fix it.

Ok, by editing the values I was able to get access to the UI, unfortunately it shows me the list of workflows, but when I click on any of them, it gives me the following error:

There was a problem initializing the workflow: Workflow with ID 'X' could not be found.

I am guessing since it didn’t take me through the wizard I went through on the Docker version, it did not assign my ACL account access to my basic auth owned workflows. Any ideas how I can fix this?

Hey @djangelic,

That is odd, I have just updated my Mac desktop app to 1.4.0 and I don’t get the email login page. Are you seeing this when loading the app or when following a webhook? Do you maybe have 2 env files in the ~/.n8n directory?

I’m having the same issue… and also new here.

I have an account created on n8n.io and when I open the desktop app, it gives me an email / password login. However, the email / password combo for my account doesn’t work. Neither does the credentials in the .env file. What the heck am I doing wrong here?

Hey @RaymondMRose,

Welcome to the community :rocket:

The account on n8n.io is not linked to the desktop app, It should use the credentials from ~/.n8n/n8n-desktop.env.

@ivov do you have any thoughts on this one?

Okay.

I’ve tried to enter the credentials from the .env also but it doesn’t work. It wants an email address.

User management as a feature should be deactivated on Desktop so this makes me think it’s some setting issue in the latest build of desktop. As @jon mentioned, @ivov should know more on this. He’s our resident n8n desktop expert :slight_smile:

1 Like

If you manually update the n8n-desktop.env to include SMTP options, it allows you access, but it does not perform the final ownership transfer process so the new email user has access to the workflows that the basic auth user does.

I temporarily fixed the issue by reverting to an older version of n8n desktop. I think a setting must be off, having gone through the process in docker, it’s missing the wizard that lets you decide whether you want to keep basic auth or switch to SMTP mode, and just assumes that an SMTP user exists.

1 Like

Desktop has basic auth enabled by default to protect the tunnel, so please keep basic auth enabled for desktop. Basic auth creds are auto-generated and located in n8n-desktop.env. In most cases, the user should have no need to view or edit basic auth creds for desktop.

Desktop also has user management enabled by default, like vanilla n8n. To disable user management on desktop, append N8N_USER_MANAGEMENT_DISABLED=true to n8n-desktop.env and restart. Tested this now and working as expected.

A user account on n8n.io is unrelated to basic auth and user management.

1 Like

Hi @ivov , Thanks so much for the clarification. I will attempt to upgrade today and disable user management.

Sadly that did not work for me. I set the environment variable but it still shows the login page, even after restarting it.