Unknown error at Zoho Sales Order creation

Hello, I’m trying to create a sales order in Zoho after an account & a contact are created. I get an unknown error when I run it and can’t understand why.
It was working last week when I did some test on existing records, but not anymore

Here is the error message

And here is the flow, the error message is displayed at “Create Sales Order” node

Share the output returned by the last node

Information on your n8n setup

  • n8n version: V1.1.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud
  • Operating system: mac

Would you guys be able to know what’s happening ?

Hi @Damien_Busch, I am very sorry you’re having trouble.

Is there a chance you were trying to create the same sales order twice? Running my below dummy workflow worked fine the first time:

Re-running it throws the error you have reported:

Test workflow:

Perhaps you want to delete your existing sales order in Zoho and give this another go? Or simply change the subject line? After I did either, the node would run fine again for me.

1 Like

Mmmh I’ve changed the node to Create or Update, I’ll wait for the next iteration to see if it goes until the end of the flow,
Thanks for your help !

Hi @Damien_Busch, just to confirm this still fails for me using Create or Update, and I believe this is a bug which I’ll add to our backlog for a closer look. I’d just like to confirm first whether you are seeing the same behaviour (where this operation succeeds for a new Sales Order, but not an existing one).

Hey @Damien_Busch,

I have just popped in a PR which will fix this, Once reviewed it will be merged in and available in a future release.


Thanks guys !

1 Like

OK clear, I’m still a bit surprised because the sales order should be brand new so I don’t expect it to fail for this reason. That’s why I want to see how it behaves for a whole new contact & account to see if the same error happens again.
Will keep you posted !

Hey Jon,
I just updated the version of N8N to 1.6.1, I still got issue when replaying a workflow on the upsert node, I got an error because the sales order already exists I think.

Do you know if the change has been committed in production already ?


Hey @Damien_Busch,

There was another issue I had to fix so the change for this wasn’t merged until earlier this week, The fix for this should be in hte next release (1.7.0) which I suspect will be out today or tomorrow.

1 Like

Thanks a lot !

1 Like

New version [email protected] got released which includes the GitHub PR 6959.

Nice thanks for your work ! I’ll update the version :smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.