Unsafe alarm with using traefik

Hi dear friends
In my case:
I install n8n on Ubuntu 18.x via docker according doc.n8n.io. (It run very good but unfortunately some updates like telegram trigger can not connect to my Webhook (I think) because of ssl error).
My address is like https://n8n.example.com

When I explore my address (https://n8n.example.com) it show that traefik certificate is unsafe.

So I install a ssl certificate that I buyed on my ubuntu on my n8n address.
The bad thing is that when I want to the ssl certificate work I should stop n8n and traefik by docker command and then should enable apache2.
After I disable n8n and enable apache2 my installed ssl work as a charm but the page shows forbiden access to n8n.
Could anyone please say me how to enable ssl truly on my n8n address?

Did you follow the docker-compose setup guide here:
https://docs.n8n.io/#/server-setup

Because if you do that everything should work fine and it should also create automatically a free SSL certificate for you.

1 Like

I’m so very bad friend :sob::sob::sob:

I tried everything from the beginning and it’s done.

Update: I think the problem was because of libgcrypt that was not upgrade even after ubuntu upgraded!!!

Great to hear that it works now!

Do you probably confirm my update in first post?

Sorry, do not understand what you mean.

At the beginning of the doc on n8n said:

sudo apt update
After I run this command my server said you can see available upgrade package by …list…
When I see available upgrade package I see that I should upgrade libgcrypt package by hand.

In the first install when I try to install n8n according to the doc I have the error about libgcrypt package.

In the second try I fistly upgrade libgcrypt in ubuntu by myself and then continue doc steps.

Ah, so it did only work for you after you did upgrade the package libgcrypt manually? If that is the case that is very good to know for the future if other users have a similar problem as you. Thanks!

Yes, at the first try when I try to install docker compose it show error and I forced to install it a way out of your doc.
I think it was my problem.

Great, then at least that is fixed now. Hope everything keeps on working fine!