Update 0.207.1 > 0.236.1 - 404 on /assets/{}.js.map files + slow code navigation

Describe the problem/error/question

We recently ran an update on our test environment to fix a reported issue. We went from version 0.207.1 to 0.236.1 and the process seemed to go relatively smoothly outside of a couple of issues which i’m hoping we can fix easily.

  1. Visiting our dev instance seems to 404 on a bunch of js.map files in the console. We never had this before and not sure on best course of action to rectify.
  2. There seems to be an input delay in our function/code nodes when typing. It wasn’t there before but makes editing and debugging painful.

As a side note, we are using MySQL and execution mode is set to queue. We are also still using basic auth.

What is the error message (if any)?

Information on your n8n setup

  • n8n version: 0.236.1
  • Database (default: SQLite): MySQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): QUEUE
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker

Hey @mzonecraig,

The map files is nothing to worry about, I reported that internally a while back but it is fairly low priority. A delay when typing in the code node sounds very odd and it is not something I have seen happen before.

Do you get the issue with the code node when using the private browsing mode of the browser?

Hey @Jon,

Thanks for getting back to me. No worries on the map files, appreciate that.

The delay when typing still occurs even on a private browser sadly. I’m not sure if it’s related but we also seem to be seeing a blank preview box when we open the node for the first time. After clicking it to open the full editor, it then does display the preview until we close the node and re-open.

Hey @mzonecraig,

Do you have the same issue with the code node as well?

@Jon The code node does preview and works how it should. However, it still suffers the issue with input delay.

@mzonecraig what browser are you using?

@Jon Brave browser but also tried it on Chrome and Safari with the same outcome.

@mzonecraig that is odd I also use Brave as my daily browser but have not seen this, Does this happen if you just add a code node to a new workflow and start editing?

Out of interest are you behind a proxy / vpn at all?

@Jon - Good shout! It looks like this is an issue on our main workflow as creating a new one and adding code doesn’t suffer from this issue. Also, i tried to duplicate the main workflow and that suffers with the same issue too.

No proxy/VPN on this server.

Hey @mzonecraig,

That is interesting, I guess the question now is… Can you share that workflow :slight_smile:

@Jon - I’ve just tried to paste in the code but it won’t let me post it as it’s apparently too long. What’s an alternative way to send to you please?

Hi @Jon - I can’t seem to cut the workflow down enough to get it on here and showcase the issue. It does appear that reducing the workflow reduces the delay. Could this be part of the issue? I wasn’t aware of any issues on the older version.

Hey @mzonecraig,

Normally the size of a workflow wouldn’t matter unless there is a lot of data in it when you are writing your code. Can you send a screenshot of the worklfow so I can get an idea of the size?

@Jon please see here :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.