Update Error

after i tried to update n8n with the console command docker-compose pull the domain is reachable. But it shows the message ‘n8n is starting up. Please wait’
And this has been going on for hours.
The server is 100% busy. And i didn’t have any problems with the performance before. What can I do to use my n8n installation again without losing my workflows?
I have already tried several things, but it does not want to succeed. Here is a message when I try to open the log:

root@Ubuntu-Server:~# docker logs root_n8n_1
License manager not initialized
Last session crashed
n8n ready on, port 5678
Migrations in progress, please do NOT stop the process.
Pruning was requested, but was not enabled

Hi @Markus08 - sorry you’re running into this!

Can you let us know what version of n8n you’re upgrading from, and what version you’re upgrading to? Any version from 0.234.0 and after has a mandatory database migration that could take several hours or more depending on the size of your database, and it’s important to let this migration run fully.

If you’re able to also post logs, that might help us confirm :+1:

Actually Markus - I see that @krynble is helping you in another thread. He’s the best person to chat to about this, and he’ll reply as soon as he can. I’ll be locking this thread in the meantime :+1:

1 Like