Update to v1.14.2 success workflow still show as running


Describe the problem/error/question


I updated our n8n instance from 0.231.1 to 1.14.2 and it seems to work as expected but I notice that some workflows are showing as “running” instead of they are finished. In database I can see the field “stoppedAt” fill but the status is still “running”. It seems appended (but it’s too early to confirme that) only on webhook workflow.

Anyone else as the same issue ?

Information on your n8n setup

  • **n8n version:**1.14.2
  • **Database (default: SQLite):**postgres
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):**default
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):**Docker
  • **Operating system:**RedHat (but docker is alpine)

Hey @Kent1,

Can you stop and start the instance (not a restart) and see if that clears it up?

Hi @Jon ,

I will try but we realized the update just few hours ago and it append immediatly. We have a close monitoring on our n8n instance and we notice it just few minutes after the upgrade.

But we will try and I will let you know if it append again or not.

Thank for your help.



Just to let you know, I update in v 1.15.1 and the problem seems solved. I haven’t anymore finished execution still show as running.

Just a quick question, I notice that there is now a new field in “execution_entity” table named “deletedAt” when this field is not null I can’t see my execution in n8n interface. This field seems to be updated automaticly in periodic time, is there a way to disable this field to be fill ?

When a workflow failed I used to check why it failed and try to correct it, but as it not appears in n8n interface anymore is a bit complicate to debug. I have to update the executionId to delete the value of the field “deletedAt”.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.