Updating n8n on Windows Machine

Hi,

I have n8n installed on my Windows 10 and 11 machines. When I stop the service and run the update command, it sits there for a few seconds and nothing happens. But if I run the install command with a specific build, it works fine. I have been doing this for a few builds now and the update command has never worked for me. Every time I run the install command it resets all my config settings. Any help would be greatly appreciated.

1 Like

I’m not a Windows user. So, I don’t know what is happening. But I feel setting up with Docker is the best option Or try n8n desktop (Announcing the n8n desktop app 🖥️)

Hi @Suratwala, I am sorry to hear you’re running into this issue.

Could you share some additional details here? What exactly is happening for you when saying the install resets all your config settings? Would it delete the .n8n\config file in your home directory?

As for the problem you are having with npm update I’m not sure it’s directly related to n8n tbh. In the npmjs registry, version 0.151.0 would have the latest tag as expected. Can you confirm which n8n versions npm outdated -g --depth=0 prints for you and what npm update -g -dd n8n returns on your machine (the -dd would set the log level to verbose)?

Also, is the behaviour the same for you when using the regular command prompt or MS PowerShell (I’m wondering if the environment in the prompt you are currently using might have something to do with this)?

1 Like

Thank you @MutedJam for your response.

The config reset part was for when I used the install command to install the latest build as the update command does not work. I ran the commands that you suggested using cmd, cmd as administrator, PowerShell, and Node.js command prompt and got the same results:

If you need any other info, please let me know.

Hi again, @MutedJam,

I updated npm to the latest build and that fixed the issue.

Thank you so much for your help in diagnosing the issue.

2 Likes

I was just reading a similar suggestion at:

But it seemed a bit generic so I was currently setting up a test environment on my end for this :smiley:

Glad to hear you figured this out, thank you so much for confirming!

2 Likes

Hi @Suratwala, Did you install n8n on your window without docker? Could you please elaborate the process of the installation?

Hi @semighoti,

Yes, I am using it without Docker on Windows.

These are the steps from my notes, if you get stuck at any point, send me the error message and it may jog my memory.

  1. Install Node.js
  2. Run PowersShell as Administrator
  3. Run npm install n8n -g
  4. Update the npm version if available: e.g. npm install -g [email protected]
  5. Run n8n - this will save the config and database.sqlite files to C:\Users\<UNSERNAME>\.n8n folder
  6. If you see an EPERM Error on path C:\Windows\System32\LogFiles\WMI\RtBackup, change the OWNER on ‪C:\Windows\System32\LogFiles\WMI\RtBackup to EVERYONE
  7. Remove Deny permission for Everyone and Add Allow permission for Everyone on C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Windows\INetCache\Content.IE5
  8. Delete database.sqlite from C:\Users\<USERNAME>\.n8n
  9. Run n8n - if all goes well, this should show a message saying:
Editor is now accessible via:
http://localhost:5678/
  1. index.js in folder C:\Users\<USERNAME>\AppData\Roaming\npm\node_modules\n8n\dist\config contains system config options.

All the best :slight_smile:.

2 Likes

@Suratwala, Thank you so much, let me try it.

I have another question, How to change http://localhost:5678/ to https://mydomain.com to use webhooks and other authorizations?

Hi @semighoti,

You are most welcome.

All customisation settings are in the index.js file located in folder C:\Users\<USERNAME>\AppData\Roaming\npm\node_modules\n8n\dist\config.

1 Like

Thank you so much. I appreciate it very much.