Upgrading n8n from 0.236.3 to 1.0.4

kubectl logs n8n-f99b95bf-cgqbk -n n8n

SyntaxError: Invalid or unexpected token
at Object.compileFunction (node:vm:360:18)
at wrapSafe (node:internal/modules/cjs/loader:1124:15)
at Module._compile (node:internal/modules/cjs/loader:1160:27)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1250:10)
at Module.load (node:internal/modules/cjs/loader:1074:32)
at Function.Module._load (node:internal/modules/cjs/loader:909:12)
at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
at node:internal/main/run_main_module:22:47
We are hosting n8n in AKS, on updating the version from 0.236.3 to 1.0.4, above error hitting in logs(Crashloopback)
Warning BackOff 12s (x5 over 62s) kubelet Back-off restarting failed container n8n in pod n8n-f99b95bf-cgqbk_n8n(261172d4-6b58-4061-9fc7-73824f474530)

kubectl logs pod/n8n-79f46c6457-fjmcc -n n8n
› Error: command /bin/sh not found
tried with 1.0.5 version and throws above error

I encountered the same error when going from 0.219.1 to 0.224.1, right now.

After checking out this: Docker tag 1.0.2 and then latest - #6 by Jon, i ended up commenting the ‘command’ line completely and that seemed to have worked.

    - args:
        - /bin/sh
        - -c
        - sleep 5; n8n start
      image: n8nio/n8n:0.236.3

When version 0.236.3, n8n running successfully, upgrading to 1.0.4 or 1.0.5 throwing error

Worker node running in statefulset updated to 1.0.5 and running successfully, but the n8n with Postgres connectivity and redid is in deployment throws error in version 1.0.4 or 1.0.5 which works perfectly fine with 0.236.3

Hey @Shalini,

There were some changes made in 1.0 looking at your example the issue will be this…

- args:
        - /bin/sh
        - -c
        - sleep 5; n8n start

Can you update this to the below which should work.

- command:
            - /bin/sh
            - -c
            - sleep 5; n8n start

It worked, thanks

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.