Uploading a file with FTP does not work - timing out

Extract json to csv and then uploading the CSV file to a FTP location. the upload is taking forever and not ending. Tested the same FTP using filezilla and that works absolutely perfect, but using the same configuration from FTP connector does not work.

What is the error message (if any)?

not showing any message.

Please share your workflow

workflowid - ahHFOinn2knw2ELR

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: cloud version.
  • Database (default: SQLite): NA
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default on cloud
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: NA

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @vikram,

Welcome to the community :tada:

Can you share the error message you get when it times out? Could it be that the FTP server you are connecting to possibly needs to allow the n8n cloud IPs for the connection to work?

Hi @jon
The problem is that it does not show any error message but continues to just run and i had to explicitly stop it after 3-4 minutes of execution… its a 2kb file. I am able to upload files to the same FTP using filezilla without any issue from several different places which have NOT been explicitly whitelisted as such. so, i assume that the FTP would not need any IP whitelisting. what do you think would be best way to troubleshoot this as we really need to get it working today for demonstrating the success of our n8n usage in our project.

here is the screenshot from executions

Hey @vikram,

That is really unusual, Are you just using FTP or is it FTPS. When you first access the server using filezilla does it have any interactive prompts that need to be completed?

Do you also know what FTP server you are connecting to is it pureftpd or something else? What you are doing should in theory be fairly straight forward and it is working for me with a test ftp server :thinking:

Hi @Jon I tried using FTP and SFTP both and could NOT find FTP-S anyways in the n8n portal.
To get the solution working, i just wrote basic C# code to upload to the same SFTP endpoint and it worked absolutely fine without any issue and using same credentials that i ve tried to use in my n8n credentials.

the FTP server is freeftpd and NOT pureftpd

Hey @vikram,

Perfect, I will set up a freeftpd server later to see if I can reproduce the issue, I know sometimes if your FTP server is configured to use StartTLS it can cause issues as it trys to swap to FTPS which we don’t support.

Oddly enough though SFTP should work as I use that in a couple of workflows as it us my preferred transport method.