Using jira custom field

We updated to latest build and keep getting this error. Is this permission issue with API account we are using or something else ? Thank you in advance, the amount of new features you all add is insane

I tried the following as well

The error message it’s ok. You have to set the expression in the field value not in the field id. In the fieldId just select the field you are interesting in.

Im sorry not really following here.

My customer field ID is 15604, that’s all I need to write in fieldValue ? the FieldID always has no data for me.

No, in the field value you need to provide the value with an expression. Is the field id loading for you? What type is the custom field you are trying to set?

the field id will not load for me. the very first photo is how I see it originally after selecting project and type of ticket to create.

Ahh, ok, now I get it. I thought the Field ID was loading for you. It should load the custom fields for you. I’m gonna investigate. In the meantime, you can always set also the Field ID using an expression.

I saw someone else asked about how to use Component/s field that is built in JIRA. Could you help me writing expression to use it ? I know ID of the components I want to use but I don’t know how to tell n8n about it so it can talk to JIRA properly. Thank you for your help on this.

@Artie_Sobol yes, can you share the workflow you are using?

The field id has to be set to {{“customfield_15604”}} using an expression.

The field value depends on the custom field type. If it’s a text, then you can type in the value in the text box. If it’s another type, then you can set the value using an expression. Similar to what I did with the field id expression above.

Im sorry to bug you again on this… I’ve been struggling with this all day :smiley:

{{"[{“name”:“20800”}]"}} I wrote this for my expression as I need an array.
Results look like this: [{“name”:“20800”}]

I have a feeling im making a really silly mistake and can’t catch it. I keep getting error that components data is not array.

I was able to fix the first part with your help just can’t get the array in there

@Artie_Sobol check the example below. Do that in the field value.

omg thank you so much !

Glad that it worked. Let’s us know if you have other question. Have fun.