Using Microsoft Teams through HTTP request


I was trying to use Microsoft Teams node to post message in a specific channel (which can be done and work perfectly) and then be able to comment a particular message (which is not currently possible) :

Then I tried to look at this documentation Send replies to a message in a channel - Microsoft Graph v1.0 | Microsoft Docs to use Microsoft graph API directly. But it is mentionned that the Auth in the header request need a “Bearer token”.

I found this documentation Get access without a user - Microsoft Graph | Microsoft Docs, that explain how to create an app in Microsoft Azure, and through multiple http requests get a “Bearer Token” at the end.

I tried to follow the documation and make the HTTP request through the n8n node, but it never worked…

I put everything as in the documentation (client ID, client secret, tenant ID, scope…) in the OAuth2 header but it doesn’t work, and I get this error message :

Which is not very relevant…

I was wondering if you had any idea maybe.
Thanks in advance.

Information on my n8n setup

  • n8n version: 0.153.0
  • Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm,, desktop app]: I was doing testing in Desktop app, but it should be on our own server later…

Hi @Polz, welcome to the community :tada:

I am sorry to hear you’re having trouble here. The error message is indeed not particularly relevant so I won’t be able to confirm the exact cause of the problem. Could you share the problematic node with me (you can, of course, redact any confidential values)? You can simply select the node on the n8n canvas and press Ctrl+C to get the underlying JSON code.

I haven’t used these MS APIs yet, so it’ll probably take me a while to get the hang, but am happy to look into this.

Thanks !
I can share with you the node, but I don’t know, it’s just a basic HTTP request with a OAuth2 authentification :

(I have only removed the tenant ID from the URL)

I have just followed the 2nd documentation I’ve mentionned for the auth…

Hi @Polz, apologies for my late reply here. Any chance you can upgrade your n8n version and retry this request? With version 0.156.0 we now show the error body of failed requests and I suspect this might be helpful here. The latest desktop version available on our website uses version 0.160.0 so would include this improvement.

@Polz did you ever get it working ?

I’m having some issues here also using MS Teams through the HTTP request, it’s only because the standard N8N Teams nodes/dropdowns don’t appear to be able to do some features that I want , e.g. create NEW oneOnOne chat with a colleague

I created a manual credential , connected to my microsoft account, using pretty much the same credentials as the N8N Teams credential, but in the manual credential I have to put the requested scopes etc and all works with subsequent URL requests etc … but the next day my N8N workflow stops working and and I have to re-connect my credential, which somehow refreshes my token ???

If I use the N8N Teams Credential with a simple chat to an existing oneOnOne chat I have no problems.

As I said I’m having to use my manual credential because the existing N8N Teams nodes appear to be lacking in functionality.

Information on my n8n setup

  • n8n version: 0.198.2
  • Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hey @0101binary0101,

Can you open a new thread for this and fill out the template provided so that we don’t bring back an old topic, You may have a different error message as well.

I am going to get this thread closed for now.

1 Like