Using Todoist Webhooks

Hi everyone!

This is my first post here, I’m happy to join this community (I’m a big fan of this tool).

Describe the problem/error/question

I’m trying to use Todoist webhooks but I can’t make them work with Todoist (I’m trying to catch task creation for now).

  • On Todoist, if the webhook callback URL is set with the n8n URL, adding a task to Todoist does nothing (I tried both test and production URLs), the n8n webhook node is never triggered.
  • On Todoist, if the webhook callback URL is set with something else, it seems to work and send the data when adding a task in Todoist.
  • On another site that allow webhooks, if I specify the n8n webhook URL, it works too.

Do I miss something ?

Thanks for you help!

Information on your n8n setup

  • n8n version: 0.222.1
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker on a NAS
  • Operating system: DSM7 (Synology)

Hey there @Artigan - welcome to the community :tada:

I’ve tried recreating this workflow and creating my own Todoist app and have n8n listen for a webhook URL, and yet I can’t seem to get these to fire off either. I also tested, and no dice :thinking: They may require a very specific path, so you might need to contact Todoist support and reach out to them.


Hey @Artigan,

Just to check have you followed the Todoist API docs and completed the OAuth process at least once from n8n?

I found that once I did that the webhook would work.

This is mentioned in the Todoist docs here: Sync API Reference | Todoist Developer under " Webhook Activation & Personal Use"


Just as a heads up, it looks like Todoist was experiencing some issues earlier today with their webhooks:

Which may have also had a hand in this for both of us when testing :see_no_evil:

Hey @EmeraldHerald and @Jon,

Thanks for your (fast) replies!

@EmeraldHerald : I tried to use it test it with yesterday and it worked (this “half-success” led to the second point of my first post). This Todoist issue you saw on Twitter should be the reason of not showing anything. I guess we have to wait before trying again :crossed_fingers:

@Jon : Thank you for your suggestion. I followed the Todoist API docs but I may have forgot to do something. I’ll try to redo the steps, just in case.

1 Like


@EmeraldHerald It seems Todoist webhooks are back again :pray:
However, after a try, it still didn’t work on my n8n instance. It works on, (using the test token Todoist provides, I believe).

I removed my Todoist OAuth credential on n8n and also removed the app on Todoist to start a fresh install of webhooks. But I encounter this error when I try to connect my account (in n8n’s credentials page):


@jon I also followed the Todoist docs, especially the “Webhook Activation & Personal Use” part but it asked me for a param named “state” when calling url. Where can I find this param?

Hey @Artigan,

That scope error could be down to a bug found yesterday while looking into this, If you open your browser dev console (normally F12), Click on the network tab then click on the sign in button. The network tab will update and you will see something like this…


If you copy that data value from the right and pop it into a text editor find the below


and replace it with


Then pop the full url in your browser and it should work, If the above with changing the URL is a bit too much send me a DM with the data output and I will sort the url out for you.


Hey @Jon,

I tried many things but I didn’t know the network tab. Thanks for the tip! It may be useful for some professional and personal projects!

Following your steps , I managed to make the sign in to work (just had to fix a typo, removing the A on data:Aread_write).

Unfortunately, I still don’t have webhooks working :-/

I tried two things :

  • On Todoist, I set “Webhook callback URL” to the webhook node test URL, then execute the workflow on n8n and add a task to Todoist.
  • On Todoist, I set “Webhook callback URL” to the webhook node production URL, then save the workflow n8n, add a task to Todoist and check the “Executions” tab.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.