Viewing execution in chrome causes chrome to crash

Not a n8n problem, at least, I don’t believe so. I’m just hoping someone has some suggestions.

When I try to view an execution for any but the most simple of flows, I get an Aw, Snap! page. If I refresh, it just loops. I have to edit the URL to go somewhere else to get out of it.

I have tested in Chrome, Safari, and Firefox.

  • Chrome crashes the window. Other running Chrome tabs or windows seem unaffected.
  • Safari loads the execution just fine.
  • Firefox gives a warning, “This page is slowing down Firefox. To speed up your browser, stop this page.” The warning eventually goes away and the execution is displayed.

Viewing this execution works:

An execution from this flow won’t load at all.

In Chrome, I’ve tried turning off all extensions and clearing the cache, cookies and history. This made no difference.

I just installed Firefox and it only has the 1Password extension.

I’m running:

  • n8n version 1.15.2
  • Postgres, but this happened on the default db as well.
  • n8n running in Queue mode on Docker on Digital Ocean.
  • Running on Ubuntu 22.04.3 LTS

Hi @russellkg, I am very sorry you’re having trouble. I was unfortunately not able to reproduce your problem, but I suspect this is because I don’t have the exact same data coming from my sub-workflows you are having.

Perhaps our frontend man @Mutasem has an idea what might be going in your case?

@russellkg is there a lot of data in the execution? I assume so, which might be why the tab is crashing. We still have to do a lot of work to make n8n performant on the frontend.

Here are some suggestions to troubleshoot and potentially resolve the issue:

  1. Update Chrome: Make sure you are using the latest version of Google Chrome. Outdated browsers can sometimes exhibit compatibility issues.
  2. Hardware Acceleration: Try disabling hardware acceleration in Chrome. To do this, go to Chrome Settings > Advanced > System, and turn off “Use hardware acceleration when available.” This might help with rendering issues.
  3. Incognito Mode: Try opening the n8n execution view in an incognito window. This can help determine if the issue is related to any cached data or extensions.
  4. Check for Errors in Console: Open Chrome Developer Tools (F12 or right-click and select “Inspect”) and check for any errors or warnings in the console tab when the “Aw, Snap!” error occurs. This might provide more specific information about the problem.

To assist you better and diagnose the performance issue accurately, could you provide a performance trace or profiling data of the affected execution?
This will help us identify any potential bottlenecks and take appropriate actions to resolve the issue.

Hi @mutdmour,

I’m up to date, I’ve tried incognito and looked in the console. I just tried turning off hardware Acceleration, that did not resolve it.

I do believe this is related to the amount of data I’m handling. With that in mind, I’m looking at ways to create seperate runs. If I work with only one client per run, that will limit the amount of data in the workflow. Hopefully, that resolves the browser crash.

For the record, this happens in two places. When I try to view the execution, and when I manually execute the whole process.

I’m going to work on that and see what that does.


We have recently been able to reproduce this with an internal workflow. Will hopefully ameliorate issue soon.


Hello Everyone, I am facing the same issue using self-hosted version 0.234.1
Do you have any suggestion?

Hi Gabriele,

I would highly recommend upgrading to the latest version. You can see what the lastest is, and how to update inside Docker here.


I have the same issues! And I tried in Chrome and Edge. My n8n version is updated

Hello. We are working on a fix here fix: Open executions with large number of execution items by mutdmour · Pull Request #8423 · n8n-io/n8n · GitHub. Should hopefully be included in next release.


Have been released now in 1.27.1. Please let me know if this fixes the issue. Thank you for patience with this. Tested with internal workflow with over 40k items in workflow with no issues.


New version [email protected] got released which includes the GitHub PR 8423.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.