Webhook Binary not working properly after update

Describe the problem/error/question

I just updated from pre-version 1.0 to version 1.7.1

Now when the Webhook gets triggered from my website’s form submission, instead of receiving the input parameters in the body and the image file separate as a binary, I get the whole form submission as a binary file, and the image just appears as text inside that binary file that I receive.

Images below show that the Body parameter is not displaying anything, and the Binary tab has a file with all the inputs.

What is the error message (if any)?

No error messages

Please share your workflow

“meta”: {
“instanceId”: “4a95abc39561cc37afb66ee4563338e768258a4eb680384874187763869a6a28”
“nodes”: [
“parameters”: {
“httpMethod”: “POST”,
“path”: “requests”,
“options”: {
“binaryData”: true,
“binaryPropertyName”: “data”
“id”: “52e3d2fe-80d6-4216-ac65-6029b9a0a294”,
“name”: “Webhook”,
“type”: “n8n-nodes-base.webhook”,
“typeVersion”: 1,
“position”: [
“webhookId”: “2552a9c7-4d7a-4c34-a7ae-830ac4b8701b”
“connections”: {}

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

Everything is set as default, I didn’t change anything in the console files.

  • **n8n version:1.7.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Running from Digital Ocean via Docker and Caddy
  • Operating system: I’m running off of MacOS Monterrey. But N8N is not installed on my computer.
1 Like

Solved it literally 1 minute after posting this :man_facepalming:

All I had to do for some reason was turn Binary Data off, now I receive both binary data and body parameters.

*If you are troubleshooting this, make sure your HTTP Method is POST.


Thanks for the solution. I looked through the release docs and I didn’t see any note that this was a planned change. Curious if this was intentional or a bug to keep an eye on: turning off the data toggle renames the files in my flow, so I’ll need to revisit this if something changes.

Happened to some of my work too, this actually caused some problems for me. While I also figured out how to at least temporarily solve the problem, a few inputs to this node, that is used for a client, became binary files all together, and I haven’t been able to retrieve the data that was In there. Does anyone know how to convert these bin files back to a multipart/form?

Did you try the “Move Binary Data” node to convert the Binary back to JSON ? Not sure if this will solve your problem but worth a shot.

Yes, thanks, I tried that but unfortunately it gives me errors in the convert node… I suspect there is something very wrong with this because the data seems broken and I have now been forced to go through all my apps and disabling this option. Like the post above, I suspect that we will need to keep an eye on this and revisit them again later on.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.