Webhook configuration

Hello guys.
I try to configure a webhook to receive 2 files. One is a txt and the other a xml. I have to put the Binary data option to on to avoid an error message

With the option configure to on it works but I receive a “multipart/form-data” format and not 2 separate files.

How can I configure my webhook to receive separate files since it is difficult after to split informations.

I use a curl command but I have the same result using postman and trying to send both files.
I try using only one variable “data”

Or 2 differents:

For information it was working well in 1.20 but since the update to 1.21.1 I begin to have the problem.

Thank you for your help

Information on your n8n setup

  • **n8n version:1.22.4

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • **n8n version: 1.22.4
  • **Database (default: SQLite): don’t know
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): desktop app
  • **Operating system: linux

This bug was accidentally introduced in a refactor couple of weeks ago, and was fixed here this morning.
This fix will be released in the next day or two.

Hello.
Thank you for your answer. I didn’t find this information myself sorry.
Have a nice day

New version [email protected] got released which includes the GitHub PR 8256.

2 Likes