Webhook dont receiving data from whatsapp business app

Describe the issue/error/question

I receive a 404 error just opening n8n. I Can send message but dont receive. At last i try to run with tunnel - The test to configure Webhook was sucessfull and when i send message too but cannot receive response.

Steps to reproduce:

  • restart n8n
  • activate the workflow using the toggle
  • running execute workflow before test to send message
  • Workflow stay spinning
  • I tried to start standard and also with tunnel

What is the error message ? :

ResponseError: The requested webhook “POST Cristal-test-0123456789” is not registered.
at ActiveWorkflowRunner.executeWebhook (C:\Users\mario\AppData\Local\Programs\n8n\resources\app\node_modules\n8n\dist\src\ActiveWorkflowRunner.js:129:23)
at async C:\Users\mario\AppData\Local\Programs\n8n\resources\app\node_modules\n8n\dist\src\WebhookServer.js:41:24 {
errorCode: 404,
httpStatusCode: 404,
hint: “The workflow must be active for a production URL to run successfully. You can activate the workflow using the toggle in the top-right of the editor. Note that unlike test URL calls, production URL calls aren’t shown on the canvas (only in the executions list)”

Please share the workflow


Share the output returned by the last node

It is the sucessfull webhook config

Information on your n8n setup

  • n8n version: - 0.182.0
  • Database you’re using (default: SQLite): - SQLite
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via: desktop

Hi @Thiago_Flaminio, welcome to the community!

I am sorry you are having trouble here. Based on your error message:

it seems the webhook is reaching n8n but your workflow isn’t enabled. Have you tried enabling it via the upper right corner of your workflow?


Hi @Thiago_Flaminio.
The same error response is given when the request sent is of the POST type but the system expects a GET type

1 Like

Hi Muted
i guess the workflow image above dont uploaded but my workflow is enabled
Other issue, some times the app is opened likes image below

I will try to reinstall, if you have any troubleshooting i’ll feel thankfull

Hey Mauro.
Thanks for response
i am using GET method.

Hey everyono
I Just reinstall and it was resolved.
Thanks for all

1 Like