Webhook from Nocodb to N8N with strange caracters

Describe the issue/error/question

Sending a Webhook from Nocodb to N8N

Please share the workflow

Webhook received without any problem. But it comes with extra caracters.

Webhook reveiced in N8N

"body":
{
"{"Id":123,"Data":"2022-11-06T10:45:51.864Z","Hora":"11:00","title4":"[{\"url\":\"https://nocodb.com/dummy.png\",\"title\":\"image.png\",\"mimetype\":\"image/png\",\"size\":0}]","title5":"Text","title6":"Long text","title7":null,"title8":"output","Atualizar":true}":
}

It comes with "{ at begining and }": at the end

Webhook reveiced from https://webhook.site/

{
  "Id": 123,
  "Data": "2022-11-06T12:39:04.345Z",
  "Hora": "11:00",
  "title4": "[{\"url\":\"https://nocodb.com/dummy.png\",\"title\":\"image.png\",\"mimetype\":\"image/png\",\"size\":0}]",
  "title5": "Text",
  "title6": "Long text",
  "title7": null,
  "title8": "output",
  "Atualizar": true
}

Is there anything the from N8N side?

Information on n8n setup

  • n8n version: 0.200.1
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @lsoldado, I’ve slightly edited your post to keep the original formatting you have used.

I am still not sure I fully understand the problem though. Perhaps you can share a screenshot of wgat your data looks like in n8n and describe what you want to achieve? Are you running into any trouble accessing the individual fields such as Hora?

Hi,

My question is, the webwook comes with "{ at begining and }": at the end

Thanks for sharing @lsoldado! After playing around with Nocodb for a bit it seems they send over JSON without the correct header. Can you try adding a Content-Type: application/json header like below?

Without it, n8n tries to read the payload as a key:

With the correct header, n8n parses the JSON data as expected:

image

Thanks for the HELP!

Yes now it works.

1 Like

Glad to hear, thanks so much for confirming!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.