Webhook node showing n8n cloud tunnel endpoint instead of WEBHOOK_URL

Describe the problem/error/question

When creating a Webhook node, the URL shown is to an n8n.cloud endpoint and NOT my WEBHOOK_URL setting.

What is the error message (if any)?

There is an error message in the docker compose log about a duplicate key, related to webhooks.

n8n-postgres-1  | 2024-01-08 19:29:43.749 UTC [33] ERROR:  duplicate key value violates unique constraint "PK_b21ace2e13596ccd87dc9bf4ea5"
n8n-postgres-1  | 2024-01-08 19:29:43.749 UTC [33] DETAIL:  Key ("webhookPath", method)=(684d35df-a3da-495b-9a4b-cae03e802c05, POST) already exists.
n8n-postgres-1  | 2024-01-08 19:29:43.749 UTC [33] STATEMENT:  INSERT INTO "public"."webhook_entity"("workflowId", "webhookPath", "method", "node", "webhookId", "pathLength") VALUES ($1, $2, $3, $4, DEFAULT, DEFAULT)

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.21.1
  • Database (default: SQLite): PostGres 11
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker compose
  • Operating system: Ubuntu 20.04

Hey @dbayer,

It shouldn’t be using an n8n cloud url but my first thought is maybe you are starting n8n with the tunnel option, Can you share your compose file and the env options you have set with anything private replaced with mock values?

I just tried to create a new webhook, and it’s using the correct URL. Maybe I tried to soon after restarting my container, after updating the docker-compose file.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.