Webhook Node Stops to listening to the Source


The node Webhook seems not to be working correctly.
When I create a workflow, the node works for one or two days and then doesn’t work anymore.

Sometimes to change the node, obtaining a new URL works, sometimes not.

It doesn’t generate an error, just stops listening to the source. I have tried more than one app source.

Last Workflow That Worked Correctly

Results Returned by n8n:

Information on your n8n setup

  • Running n8n via [Docker, npm, desktop app]:

Assuming the workflow is still active and the server didn’t reboot or anything like that.
Do you have a log of the sending Application stating it does actually send the Webhook?

Hey @Lucas_Pontes,

Welcome to the community :tada:

Are you using Desktop or something else with the tunnel option? The tunnel URL can change if the app crashes or the network connection drops which is why we don’t recommend it for production use.

1 Like

I found it in the documentation that suggests that the n8n app is installed with the tunnel option by default.

If it is the case, how can I change this option?

(Reference: Desktop app - n8n Documentation)

Hey @Lucas_Pontes,

I guess that answers the question of how you have n8n setup :slightly_smiling_face:

So if you are using desktop it is a bit tricky as you will need your own domain and to set up port forwarding on your router so that the outside world can access n8n.

Another option could be to use something like ngrok and use that as a tunnel solutions. To change the URL you can find the ngrok steps here: N8n Desktop custom Webhook url ngrok - #4 by Jon the same theory would apply to your own domain as well.