Webhook path

Hi, I have a question regarding webhook:

I created a new node and copied and pasted all webhook codes for that. Just changed its name. But its ‘Path’ property is empty!
image

I didn’t change any anything other than a name and display name in code.

What’s the problem you think ?

You can set the path to whatever you want. It just has to be unique across workflows.

Thanks @jan for the answer. But in the webhook node, the path automatically set to a unique string like this: 66bd8a5a-0538-44da-ac27-0898ad5047bg
I need the exact functionality.

Yes by default will it always set a unique path. Can not think of a reason why it would not do that. Unless you copy paste a node with an empty path.

1 Like

Here is the path property:
{
displayName: ‘Path’,
name: ‘path’,
type: ‘string’,
default: ‘’,
placeholder: ‘webhook’,
required: true,
description: ‘The path to listen to.’,
},
and here is the webhooks array:
webhooks: [
{
name: ‘default’,
httpMethod: ‘={{$parameter[“httpMethod”]}}’,
isFullPath: true,
responseCode: ‘={{$parameter[“responseCode”]}}’,
responseMode: ‘={{$parameter[“responseMode”]}}’,
responseData: ‘={{$parameter[“responseData”]}}’,
responseBinaryPropertyName: ‘={{$parameter[“responseBinaryPropertyName”]}}’,
responseContentType: ‘={{$parameter[“options”][“responseContentType”]}}’,
responsePropertyName: ‘={{$parameter[“options”][“responsePropertyName”]}}’,
responseHeaders: ‘={{$parameter[“options”][“responseHeaders”]}}’,
path: ‘={{$parameter[“path”]}}’,
},
],

Should I do anything else for the path to be set automatically ?

I noticed that here
image
The name property must be webhook, so path would set automatically.

Hey @jellybean!

Are you creating your own Trigger node? If yes, you can follow the steps mentioned here: Creating your first trigger node | Docs

1 Like

Thanks @harshil1712, but it doesn’t say anything about path, which must be set automatically.

1 Like

Sorry did not understand that you really create a totally new node.

In this case you should set:

  isFullPath: false,
  ...
  path: "whatever",

and then remove the path parameter from the node. It will then always use the id automatically as part of the path.

1 Like