Webhook - Problem

Hi,

I am having a problem with my new webhooks.

I already have several webhooks that are working properly.

Webhooks do not go into testing or production.

Looking further, I have this message.

{“code”:404,“message”:“The requested webhook “GET 55418095-3240-4754-b5f4-dbedc4d39427” is not registered.”,“stack”:“ResponseError: The requested webhook “GET 55418095-3240-4754-b5f4-dbedc4d39427” is not registered.\n at ActiveWorkflowRunner.executeWebhook (/home/debian/.nodejs_global/lib/node_modules/n8n/dist/src/ActiveWorkflowRunner.js:67:23)\n at async /home/debian/.nodejs_global/lib/node_modules/n8n/dist/src/WebhookServer.js:47:24”}

I see that for HTML Method it is in GET even though I have chosen POST.

Do you have any idea where the problem may be coming from.

Thanks for your help :smiley:

Welcome to the community @Lyoto!

The problem is exactly that “POST” <> “GET” thing. You told n8n to listen for “POST” requests but then you make apparently a “GET” request instead. For that reason the error message. It says there is not webhook for “GET”, which is correct because you created only one for “POST”.
So you either have to change the Webhook-Node and set it to “GET” or you have to make a “POST” request instead.

1 Like

Thank you for the answer.
My way of testing was not good :stuck_out_tongue:

Indeed when I do the get test it works.

On the other hand when I return to my basic problem which is a POST this time (elementor form), I have an error message each time. However, I already use several forms that work.

I cannot find where the problem is coming from.

FYI, I have this error message.

Hi @Lyoto,
I had that issue some time ago, cannot recall well what I did, but I think in the functions.php of the site I just configured elementor form to do a remote post having the webhook as post. You can read more here:

As you can see in the code, we force the form to do a post via “wp_remote_post”.

// A send custom WebHook
add_action( 'elementor_pro/forms/new_record', function( $record, $handler ) {
    //make sure its our form
    $form_name = $record->get_form_settings( 'form_name' );

    // Replace MY_FORM_NAME with the name you gave your form
    if ( 'MY_FORM_NAME' !== $form_name ) {
        return;
    }

    $raw_fields = $record->get( 'fields' );
    $fields = [];
    foreach ( $raw_fields as $id => $field ) {
        $fields[ $id ] = $field['value'];
    }

    // Replace HTTP://YOUR_WEBHOOK_URL with the actuall URL you want to post the form to
    wp_remote_post( 'HTTP://YOUR_WEBHOOK_URL', [
        'body' => $fields,
    ]);
}, 10, 2 );
1 Like

Thank you for the feedback.

It reassures me that I am not the only one having this problem. If anyone has a more in-depth lead, I take it because I have been looking for several days.

What I don’t understand is that the same webhook link works on another site in another hosting.

Certainly a stupidity …

I did a couple of tests:

And using plain “POST”, the form works perfect (with webhook on POST), with “GET”, I get same error as you:

Webhook Webhook Error
This Message is not visible for site visitors.

If I force with wp_remote_post, it works but I still get “X Error”.

So for me the plain POST is working fine, but GET is not working.

I understand, but unless I’m mistaken, elementor forms automatically exit POST.

I tested with a different webhook from N8N and it works and I tested the n8n webhook with my other site which works perfectly with n8n and there no problem.

I don’t understand where the problem comes from

Well, I am very fresh yet in these things, the only thing I see is you are using:

image

And in mine I just have “Response Mode: On Received”

I am not yet a great expert either.

I just tested your solution but it does not solve my problem unfortunately

Bummer :confused:. Do you have any configurations or Firewall/Plugins that could block this?

Many thanks for the feedback.

I will check with this new host if a problem cannot come from a firewall.

So just to make sure I understand it correctly. You have n8n running on an external server with its own subdomain? And in the URL you copy from the Webhook-Node it also uses that subdomain?

I have an external server that only runs for N8n and my various automations.

This server does indeed have its own domain.

And they are already using different webhooks, api, …

On the other hand, I am encountering a problem to link the new webhooks with an elementor form

Just for the record, @Jorge_M you were right. The new host I’m working with automatically blocks port 5678

Do you know what other port I can use for N8N if needed to change and how to change?

Apparently they only have ports 80 and 443 possible

Ah excellent, progress. Yes I think by default n8n works with 80, but 443 is also possible, maybe here @jan can give you better suggestion to another port possibility or you refer to the host itself?

You should never run n8n in production with port 5678. That will cause problems with the most services.

Here is our server setup guide:

If you follow that one n8n will run correctly on port 443 (SSL/HTTPS).