Webhook StatusCodeError 404

Hello everybody,

It’s my very first post here, I guess my problem is quite easy to resolve but I don’t find any solution in the community for now so here I go :slight_smile:

When I try to create a simple webhook following the example in this video https://www.youtube.com/watch?v=WLIDTRJGfWw&feature=emb_title

I get the following

My usecase is to get specific infos from an API and then send it to a webhook in an other workflow/

Did I miss something (obvious) here ?

Thanks for your assistance folks!

NB : My webhook setup

My HTTP request setup

Webhook test url : https://vbo01.app.n8n.cloud/webhook-test/repliestry

Hi @vinceHq

Welcome to n8n community =)

Well, to help you solve this problem I will suggest some steps we can take to diagnose:

  • For the webhook to work in test mode, you have to click the “Execute node” in the node editing window or “Execute workflow” in the main editor window
  • Once you click the Execute [workflow or node] button, then you are able to access the test URL
  • You can check if you are trying to access the correct URL by checking the webhook URLs in the top of the node editing window (it is a bit hidden) as shown below:

Let me know if you tried these steps as the error message actually indicates that the webhook is not yet registered, which means probably n8n was not in “test mode” (it goes into this mode when you click the Execute buttons).

thanks for your answer @krynble

I tried to follow your steps but I get the same results.

I do select Display Url for “Test” and put it in the HTTP Request node in the other workflow

But I still get the same 404 error saying that “GET repliestry” is not registered."

Here are some videos which explain webhook a little bit deeper. Maybe they help: