Webhooks fail when scaling with Redis

Describe the issue/error/question

Hi! I’m builing an instance of n8n using Redis scaling. Works fine, n8n connected with redis. I was testing webhooks with the webhook-test endpoint and that works fine.
The problem comes when I tried to use the prod endpoints, I get following one liner in the n8n logs:

Started with job ID: 1 (Execution ID: 142)

In redis i get the following messages repeated messages:

1642608913.526304 [0] "evalsha" "74c8631221de82c9ac8c1cb76e574a903fa0228c" "2" "bull:jobs:completed" "bull:jobs:failed" "1"
1642608913.526342 [0 lua] "zscore" "bull:jobs:completed" "1"
1642608913.526349 [0 lua] "zscore" "bull:jobs:failed" "1"
1642608913.526352 [0 lua] "zscore" "bull:jobs:failed" "1"

In the GUI executions list I can see it got started but it never stops running:

Please share the workflow

It happens with every workflow triggered by a webhook, if I Stop the execution it figures a 0 seconds runtime, so I guess is regardles of the workflow.

I’m using the docker-compose build with the n8n-custom image.

Could it be some problem with my env variables? Thanks for your time, cheers

Welcome to the community @UlisesTorrella!

Sorry to hear that you have problems. Can you please share a little bit more about your setup. Like do you use separate n8n instances for incoming webhooks? Did you also start worker nodes? What database are you using? What environment variables did you set for all the different n8n instances?

Hi jan thanks.
I’m using only one n8n instance, and I didn’t start any worker, maybe theres the issue, does the main instance not work as a worker?
I’m using postgres and set the following enviroment variables:
plus the 3 for postgres host, port and db
also NODE_OPTIONS=–openssl-legacy-provider but i don’t think is relevant

I’ll try setting up a worker

Yep that was it I missed that part, thanks a lot @jan!

Ah perfect, yes only the workers run production executions. If you do not have any running then this jobs will stay in the queue indefinitely.