WhatsApp Business parameters

Hello!

Looking for help on the new Whatsapp node. When using the resource “message” and operation “send template” I cannot get it to work on the template parameter.

I have put the template name followed by the language and code but no success. Could someone show me an example of how it should be input?

I receive this error:
ERROR: Bad request - please check your parameters
The parameter template[‘language’][‘code’] is required.

Hi @zerog, from looking at the respective pull request this node appears to have been quite a complex undertaking and I don’t know exactly how to use WhatsApp templates unfortunately. Perhaps @RicardoE105 can share some advice on how to properly use this node?

Thank you @MutedJam. Hope @RicardoE105 has some time and help me get it right.

Can you please share an example of the template you are trying yo use (you can delete sensitive information) and the workflow where you are using the Whatsapp node? Thanks

I’m just testing the node to send a couple messages before I use it in production.

I deleted the Sender Phone Number (or ID) and the Recipient’s Phone Number from the example below. My only issue is with the Template parameter. I don’t know what is the right input data I need to use on this field.

I always get this error:
ERROR: Bad request - please check your parameters
The parameter template[‘language’][‘code’] is required.

I cannot replicate the issue. For me, it works just fine. I used a very simple template. Can you share the template you used so that I can replicate the error?

Hi @zerog,

I assume that the template has been previously created in WhatsApp Manager and has been approved for use, isn’t it?

Without an approved template it is not possible to send messages via the WhatsApp Business API.

In @RicardoE105 's example, he is using the Hello World template, which is active in his WhatsApp Manager, and therefore, he can select it from the Template dropdown in the WhatsApp node.

You can find all the information about templates in the API documentation.

1 Like

Thank you for the help guys.

I was able to resolve it by looking at the config from Ricardo’s post. I typed the wrong ID and the fields were not pulling the data correctly from the API.