When the domain name is accessed, the node is always waiting

When accessed by ip+ port, it outputs normally. If you use a domain name, you will always be waiting.

My domain name is through nginx reverse proxy to n8n 5678 port. It should be working properly because the OAuth redirect URL was successfully verified.

Hi @duttchasel, this could suggest your reverse proxy config isn’t complete (n8n uses server side events to send data from the server to your browser and these don’t seem to arrive for you).

For nginx I usually go with something like this:

    location / {
        proxy_pass http://localhost:5678;
        proxy_set_header Connection '';
        proxy_http_version 1.1;
        chunked_transfer_encoding off;
        proxy_buffering off;
        proxy_cache off;

Perhaps you can double check your server block?

1 Like

thanks! This setting is useful to me

proxy_buffering off;

1 Like

Sweet, glad to hear that’s working for you :slight_smile: