Where is "One-click upgrade to the newest n8n version"?

Hi. Where is the “One-click upgrades to the newest n8n versions” for the cloud version? The doc has no info on where to find it, and I do not see it anywhere in the app.

Oddly i see a “You’re on 1.27.2, which was released 3 weeks ago and is 2 versions behind the latest and greatest n8n” (something most SaaS tools update in the background.)

But then, clicking “How to update your n8n version” goes into a buggy loop that asks me to log in again, which takes me back to the same home admin panel page. Never letting me know how to update.

How do I update? Thanks.

Root Issue Why I’m Asking

Note: the real reason I’m asking is becuase I’m getting odd OpenAI API errors that do not seem to be right, so I wonder if it’s perhaps older n8n bugs that have since been squashed.

Example: the simplest OpenAI node connection and simple prompt test used to work fine, but now says a single test = too many connections:

NodeApiError: The service is receiving too many requests from you
    at RoutingNode.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/RoutingNode.js:118:23)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:756:23)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:656:53
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:1058:20

Thanks much.

  • n8n version: 1.27.2
  • Database (default: SQLite): whatever your cloud version uses
  • n8n EXECUTIONS_PROCESS setting (default: own, main): not sure what this is
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: of server? whatever your cloud runs on. client? MacOS

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@RoundSun , try clearing your browser’s cookies. I had the same problem after I read your message and tried on my account. Worked fine once the cookies got deleted and I re-logged in.