Why my flow Loop node stop before all items are being processed and how to enable Logging on Docker

Hello I am totally new

I followed the instructions installed n8n on Digital Ocean.
I created my workflow. It runs everyday morning., And it worked well but out of a sudden, it became problematic. stop on the 28th loop

Trying to figure out why my flow loop node stops before all items are being processed, even though the task returns as executed successfully.

After I update the loop node to 1 item per batch or 2 items per batch both stop suddenly, But I dont think it is relative. It is the same after I tried to run it 4 items per batch

It used to work days ago. (It was 4 items per batch)

I tried to enable log and see if there are any clues. I added these lines into the .env file. I ran the flow and it stopped. But there were no log generated. Am I missing something here?

The server has 2GB. Does not seem to be because of the memory thing causing it to stop

Any suggestions?

Information on your n8n setup

  • n8n version: 1.32.2
  • Database you’re using (default):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, desktop app]: chrome browser scheduled trigger and test workflow

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@Blueli , are there any other nodes engaged in the loop? For example, do you use IF node, Filter or Switch? Typical reason for breaking the loop is including conditional check.

You need to make sure that an item is always returned to the Loop input. If HTTP Request is the only node in the Loop, make sure it always returns something. If you are saying the iteration stopped on the 28th run, you can easily check the returned value. You do not need any special logging to be enabled. That information is accessible from the node UI.

It also appears that the workflow takes a very long time to complete. Have you reached the workflow timeout?


Yes. You are right. It was because there was a record from the HTTP node output of nothing therefore the loop stopped. I enabled always output data. The issue is resolved! Thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.