Windows 10 firewall settings help

Since starting with a new workflow I’ve encountered a problem with the local Node.js program crashing. Restarting it seems to work for saving the workflow and other tasks that involve communication with the n8n servers.

But now that I’m at a step where the workflow needs to be communicating with the Google Sheets API I’m having an additional problem with the webhook apparently not connecting:


The crash error that I get from the local Node.js app is as follows:

PS C:\Users\me> n8n start --tunnel

Waiting for tunnel …
Tunnel URL: https://[redacted]

IMPORTANT! Do not share with anybody as it would give people access to your n8n instance!
n8n ready on, port 5678
Version: 0.81.0

Start Active Workflows:

  • Weekly Time Tracking
    ADD ID (active): 1
    => Started

Editor is now accessible via:

Press “o” to open in Browser.
throw er; // Unhandled ‘error’ event

Error: connection refused: (check your firewall settings)
at Socket. (C:\Users\me\AppData\Roaming\npm\node_modules\n8n\node_modules\localtunnel\lib\TunnelCluster.js:52:11)
at Socket.emit (events.js:315:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21)
Emitted ‘error’ event on Tunnel instance at:
at TunnelCluster. (C:\Users\ajsau\AppData\Roaming\npm\node_modules\n8n\node_modules\localtunnel\lib\Tunnel.js:96:12)
at TunnelCluster.emit (events.js:315:20)
at Socket. (C:\Users\me\AppData\Roaming\npm\node_modules\n8n\node_modules\localtunnel\lib\TunnelCluster.js:50:14)
at Socket.emit (events.js:315:20)
[… lines matching original stack trace …]
at processTicksAndRejections (internal/process/task_queues.js:84:21)

I’m running Windows 10 Pro, so this may be a firewall configuration issue. That would be an easy fix if there are instructions you can point me to on the n8n site.

Welcome to the community @ajsaulsberry!

Communicating with the Google Sheets API and Webhooks are very different things. The message you are seeing “Waiting for Webhook-Call” means that you have a Webhook-Node in the Workflow and n8n is waiting for it to get called. If you are just testing and there is no special data supplied via that call you can also deactivate the Webhook-Node and run the workflow without it. Then the message should disappear.
If you are having problems with the firewall and you are just testing locally you can also keep the Webhook-Node activate but start n8n without the “–tunnel” option. The tunnel is only required if n8n has to be reachable from the internet (so if an external service like for example Pipedrive has to reach n8n). If you just test locally and you call the Webhook yourself that is not required.

If all of that does not help and you need the data from the webhook and it really has to be reachable from the internet you really have to look into your firewall settings. Sadly do we not have a guide for that yet and also nobody which uses windows. So your best bet right now would be to google how that can be done. Anyway, before spending to much time on it I would deactivate the firewall for a minute and see if it is really the problem.

I hope that helps!