Woocommerce Images

Hello,

I am self hosting n8n and attempting to use the woocommerce node. It works, except some of the fields I can’t add anything to, such as images. Please see the attached screenshots.

Am I missing something?

n8n Version: 1.38.2
Database: SQLite
Running n8n via n8n - Executed From VSCode Terminal
Operating System: Windows w/WSL

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @Robert_Miller

for me everything is fine.

I suggest not to use VSCode to run n8n. Better to use docker.

I’ve tried Docket and couldn’t get it to run correctly. I run it natively and it’s been a workhorse till this issue. I’ll have to look closer and see what’s wrong, at least I know now it’s supposed to work.

Thank you

What is the issue you are experience with the docker? It should be much simplier, than the current one

Originally I was getting the following error:

 external volume "caddy_data" not found

So I created the volume with this command:

 sudo docker volume create caddy_data

Then it errored on the n8n_data volume so I created that:

 sudo docker volume create n8n_data

Now I am getting the following error:

Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting “//n8n-docker-caddy/caddy_config/Caddyfile” to rootfs at “/etc/caddy/Caddyfile”: mount //n8n-docker-caddy/caddy_config/Caddyfile:/etc/caddy/Caddyfile (via /proc/self/fd/6), flags: 0x5000: not a directory: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type

I originally used this instruction set:

When that failed, I tried the following two threads, will no luck:

I tried the Discord which was worthless since no one answered except to say post it in the forum.

At which point, enough time had been wasted that I installed it natively on the server so I could get some work done. I knew even if I could get it working, I would still be fighting SSL certificates and other issues.