Woocommerce node get error 400 everytime

Describe the issue/error/question

I’m trying to use the woocommerce node to get products information from my customer, but for each action (get product or order), I get a 400 error.

I tried to use another node like github and the node works successfully.

What is the error message (if any)?

NodeApiError: Bad request - please check your parameters
    at Object.requestWithAuthentication (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1015:19)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Object.woocommerceApiRequestAllItems (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/WooCommerce/GenericFunctions.js:29:24)
    at async Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/WooCommerce/WooCommerce.node.js:260:40)
    at async Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:658:28)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:585:53

Please share the workflow

  "meta": {
    "instanceId": "7d51ca17abe4c36c3bf60ee42fc363e374013fa94370b5b8b96087e0f311ab10"
  "nodes": [
      "parameters": {
        "operation": "getAll",
        "returnAll": true,
        "options": {}
      "id": "6bf19f05-dd5c-4d72-bdc1-aa0ed68c0ddb",
      "name": "WooCommerce",
      "type": "n8n-nodes-base.wooCommerce",
      "typeVersion": 1,
      "position": [
      "alwaysOutputData": true,
      "notesInFlow": false,
      "executeOnce": false,
      "retryOnFail": false,
      "credentials": {
        "wooCommerceApi": {
          "id": "1",
          "name": "Test client"
      "continueOnFail": true
  "connections": {}

## Share the output returned by the last node
The node return an empty object and I need to retrieve all product store in the customer woocommerce.

## Information on your n8n setup
- **n8n version: 0.205.0 (I also tried with the version 0.206.0)**
- **Database you're using (default: SQLite):**
- **Running n8n with the execution process [own(default), main]:**
- **Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker**
1 Like

Hi @Jean85

Welcome to the n8n community forum!

Can you double check the WooCommerce website is up and running correctly?
Also, try getting single-customer information by passing the customer ID?


Hi @mcnaveen,

Thanks to reply.

The woocommerce is up and running and I tried to make the request with the HTTP Request node with success.
I also made the test with a customer ID and I get the same 400.

Ah. Error 400 means Bad Request.

Does your WooCommerce site has proper SSL certificate? Using HTTPS right?
Have you tried getting the customer data using HTTP Request Node itself?

So, I just made this extra tests :

  1. I made an http request with the user-agent “n8n” with success.

  2. another weird things is I need to check “Include Credentials in Query” box to make a successfull connection to the woocommerce website (with n8n)

For your information, the woocommerce use the latest version available.

The ssl is correctly configured on the woocommerce and the website is public.

1 Like

Hey @Jean85,

I have just given this a go with n8n 0.207.1 and WooCommerce 7.2.0 on Wordpress 6.1.1 and it appears to be working.

The only thing I found was that for the credential test to work the “include in query” option needs to be set but if you ignore the test error it does connect and pull the data.

Would you be able to create a new set of read only API credentials and DM to me along with the URL for the site and I will see if I can find out what is going on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.