Wordpress HTTPS POST request for custom post type (Pods) just returns existing posts

Describe the problem/error/question

Sending an HTTPs POST request to Wordpress to create a custom post type, meaning the post type was created using “Pods”, just returns the list of existing posts and does not create a new post.

I was able to make a default Wordpress post with the same credentials, so the issue is not there. I’ve disabled plugins and tried but still doesn’t work.

My custom post type or pod is called “Mentors” and based on Pods REST API I am sending it to the right URL

What do you think is going wrong?

What is the error message (if any)?

Sending HTTPS Post request to wordpress custom post type but only getting back results like a GET request

Please share your workflow

Share the output returned by the last node

Output is a list of results from that custom post type instead of creating a new post

Information on your n8n setup

  • **n8n version:**1.23.0
  • Database (default: SQLite):
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):**own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):**Docker
  • Operating system:

Hey @pooria,

I am not sure I follow the issue here, If you are making a post request using the HTTPS Request node to Wordpress and Wordpress is returning a list of posts it sounds to me like the issue is going to be with Wordpress not with n8n as we will just show you what the response is from the service you are talking to.

I’m not familiar with Pods, but with Advanced Custom Fields (ACF) you need to enable API access for new content types. Perhaps that’s the case here too?

ACF or Pods both by default allow you to make API calls to the wp-json/wp/v2/{custom-post}. The problem was W3 Total Cache plugin.

I disabled it and it works.

I submitted a request on their forum to see if they have a solution.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.