Workflow active in main n8n, but inactive in worker n8n nodes

Description of the issue

We have our current n8n setup in Amazon ECS, a dedicated cluster for main n8n and another for Worker n8n tasks.
Recently we have seen a weird issue wherein the workflows are not getting triggered despite the workflow being active, on the UI the workflow is active but the workflow doesn’t get triggered.
It only gets triggered when I disable and reenable the workflow.
I believe the issue is that the workflow passed onto the workers being in inactive state

workflow

Information on your n8n setup

  • **n8n version: 0.190.0
  • **Database : Postgres
  • **Running n8n with the execution process [own(default), main]: own
  • **Running n8n via : Docker

Hi @Roney_Dsilva, welcome to the community!

I am so sorry to hear you’re having trouble.

It only gets triggered when I disable and reenable the workflow.

Can you confirm in which scenario exactly your workflow won’t be accepted as active by the workers? Is this right after creating and activating the workflow? If so, do you create and activate the workflows through the UI or through any other method?

Hi @Roney_Dsilva, in the meantime I have set up a test environment and ran a bunch of tests, but even my RabbitMQ-triggered workflow worked as expected after saving and activating it:

It’s executed by the worker, not the main instance:

So it’d be great if you could share the exact steps required to reproduce your problem.

Thank you!

Hi @MutedJam , The issue seems to occur at random, in the past 4 weeks we faced this issue 2 times. nothing was changed from our side. The workflow was showing active, but RabbigMQ queue had built up but was not getting processed/triggered.
After trying and checking all possible parameters, we reenabled the workflow, which solved the issue

Hi @Roney_Dsilva, please ignore my previous answer - is there any chance you can update to a more recent n8n version? Version 0.196.0 introduced a reconnection logic which hopefully solves this problem for you: No reconnect if RabbitMQ server restarts - #5 by jan

2 Likes

Sure @MutedJam, Thanks :slight_smile:

Will let you know if the issue reoccurs

1 Like

You may want to look at N8N_SKIP_WEBHOOK_DEREGISTRATION_SHUTDOWN. Without it if you shutdown any of the nodes they may bring down your webhooks.

Only de-register webhooks on external services when workflows are deactivated

https://docs.n8n.io/hosting/environment-variables/#endpoints

Edit: ignore me, just saw this was RabbitMQ only

Hey @Roney_Dsilva one thing to note is making sure you have only one “main” n8n instance.

Also the version mentioned by Tom certainly helps solve this issue by adding a reconnection logic, which might also be the culprit.