Workflow fails despite all nodes completing successfully

Describe the problem/error/question

One of my workflows triggers a WorkflowOperationError every time it runs, yet it completes successfully by any other standard: I get the email sent by the last node and the logs indicate that all nodes completed successfully (green checkmarks). The reason I know it fails is that I have an error workflow set up to notify me on failure, and I get a notification from this workflow every time. I have not seen this issue with any other workflow, and I have several more.

What is the error message (if any)?

Here is the full JSON sent to the error handler workflow:
“execution”: {
“id”: “861”,
“url”: “”,
“error”: {
“name”: “WorkflowOperationError”,
“timestamp”: 1691330514638
“mode”: “trigger”
“workflow”: {
“id”: “4”,
“name”: “Daily historic images”

Please share your workflow

Share the output returned by the last node

I can’t: "The execution was interrupted, so the data was not saved. Try fixing the workflow and re-executing. "

Information on your n8n setup

  • n8n version: 1.0.5 – but this issue has been around for a while
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: N/A

Hi @wolfmanstout :wave: Welcome to the community :tada:

I’ve tried reproducing this and can’t - the workflow for me is working, and it’s never triggering the error workflow. Out of curiosity, are you saving all of your execution data when you go into your settings? There’s never any indication that any node has failed? :thinking:

I have “save failed production executions” enabled, but not “save execution progress”. I tried enabling that and it failed at a different point in the workflow (not only was the error JSON different, but it didn’t send the email that happens in the last node).

Since this worked for you, I also tried copy/pasting this into a new workflow, but that did not resolve the issue either (same failure mode as I originally reported – I got the email sent by the last node, but also the error email).

Are you reproducing this on n8n Cloud? I’m guessing the execution environment might be significant here.

Hi @wolfmanstout - I am indeed trying to reproduce on cloud, which makes this more confusing as you’re also using n8n cloud.

Did you happen to catch the error that was different when it failed at a different point / did not send an email? That might help us debug this for you.

Sure, here is the failure I got when I enabled save execution progress:

  "execution": {
    "id": "885",
    "url": "<redacted>",
    "error": {
      "name": "WorkflowOperationError",
      "timestamp": 1691676106421
    "lastNodeExecuted": "Generate prompt",
    "mode": "trigger"
  "workflow": {
    "id": "tSmpYurgoHs3CYV2",
    "name": "Copy of daily historic images"

Bear in mind that this workflow does produce binary data, so it might use more memory than other workflows. Earlier in development I saw some failures that seemed to be tied to the node that outputs the binary data. But that explanation doesn’t make sense to me to explain these failures, because it is failing either after the last node completes, or before that node even runs.

Hi @wolfmanstout - I had a quick look at your cloud instance logs, and you did indeed run out of available memory with your workflow. While you can read about how to fix up those kinds of errors here: Memory-related errors | n8n Docs Though this won’t help much if you’re pulling in a lot of data :sweat_smile:

I run this daily – are you seeing that with the most recent logs? I have read that documentation, but I’m not sure what to do in this case when all nodes are completing and yet it runs out of memory at the end. That seems to me like an n8n bug – it ought to be releasing this data before doing more heavy allocations.

I’m also just not doing anything that expensive – I generate 4 images. Is there any way to increase the memory limits other than self-hosting?

Hi @wolfmanstout - I saw that when I checked earlier at the time of this post. I’m not too sure of your full n8n setup, as also running lots of workflows in parallel could cause this, as could too much binary data.

If your n8n cloud account is under the same email as your forum account, you could try upgrading - you’d have double the resources to work with, then.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.