Workflow not executing

For some reason my merge node is running twice and I think this is causing an error in my workflow. Does anyone know the solution to this?

Hey @aziadlourad,

The Merge node excepts only two inputs, but you have provided 4 inputs to it. Hence, the Merge node is executed twice. You will have to add more Merge nodes, similar to the image below

This will then pass the information to the HTTP Request node once, and you should not get the error.

1 Like

Hi Harshil,

So I’m still getting the same error. It seems to think no data is coming in when it actually is. The data is being pulled from the very first node in the workflow which is called TypeForm1

Screenshot 2021-09-22 at 15.00.01

It looks like the API is expecting the body in a different format and not JSON. Can you link the docs of the API you’re using?

@harshil1712 @RicardoE105 I cant understand whats going wrong. The API requires a string and an array which is what I am giving it through n8n. Is there anything immediate that jumps out?

Does the data need to come directly out of the merge node before it? The data I am using is from a node much earlier in the workflow.

No. Even if the data is coming from the first node, it should be fine. I am trying to replicate this. Do you have a test account or API Key that you can share with me? If so, please share it over DM

Hey @aziadlourad,

How many items are returned by the Merge node? Does it return a single item or multiple items? You can find the number of items in the node.

Screenshot 2021-09-23 at 11.15.52

If the Merge node is returning more than one item, you may want to change your expression from $node['Typeform Trigger1'].json['Startup name:'] to $item("0").$node['Typeform Trigger1'].json['Startup name:']

This new expression will use the data from Typeform for all the incoming requests. So if the Merge node returns 5 items, the HTTP Request node will be executed 5 times using the same data from Typeform for all the requests. However, if you want to only execute the HTTP Request node once, you can toggle the Execute Once option to true.
Screenshot 2021-09-23 at 11.20.42

If none of this solves your issue, let me know :slight_smile:

1 Like

Hi Harshil, perfect thank you it fixed the problem! Thanks so much

1 Like

Wonderful! I am glad it solved the issue. Have fun :tada: